summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-02-22 16:42:18 +0300
committerCaleb Maclennan2023-02-22 16:42:18 +0300
commited12bd76250663809674cdc10eb8efaaa484f979 (patch)
treecb3cc95e43a4e7b4e57bfa27b51e58647b592c3e
parentfda510ae3b58b9335ccb7343bfc9df5494b790d5 (diff)
downloadaur-ed12bd76250663809674cdc10eb8efaaa484f979.tar.gz
upgpkg: powermate-git 8.r0.ga5aed40-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD44
2 files changed, 31 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d175558ccb5..61ba5e5063d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = powermate-git
- pkgdesc = A small Linux userspace driver for the Griffin PowerMate.
- pkgver = v5.r20.g3f6459f
- pkgrel = 2
+ pkgdesc = A small Linux userspace driver for the Griffin PowerMate
+ pkgver = 8.r0.ga5aed40
+ pkgrel = 1
url = https://github.com/stefansundin/powermate-linux
arch = x86_64
license = GPL3
+ makedepends = git
depends = libpulse
source = git+https://github.com/stefansundin/powermate-linux.git
source = git+https://github.com/cktan/tomlc99.git
- md5sums = SKIP
- md5sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = powermate-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 562340efbddc..83e0d8fc05bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,41 @@
-# Maintainer: b10n <b10n@dittes.nl>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: b10n <b10n@dittes.nl>
+
pkgname=powermate-git
-pkgver=v5.r20.g3f6459f
-pkgrel=2
-pkgdesc="A small Linux userspace driver for the Griffin PowerMate."
-arch=("x86_64")
-url="https://github.com/stefansundin/powermate-linux"
-license=("GPL3")
-depends=("libpulse")
-source=("git+https://github.com/stefansundin/powermate-linux.git"
- "git+https://github.com/cktan/tomlc99.git")
-md5sums=("SKIP" "SKIP")
+_pkgname=powermate-linux
+pkgver=8.r0.ga5aed40
+pkgrel=1
+pkgdesc='A small Linux userspace driver for the Griffin PowerMate'
+arch=(x86_64)
+url="https://github.com/stefansundin/$_pkgname"
+license=(GPL3)
+depends=(libpulse)
+makedepends=(git)
+source=("git+$url.git"
+ 'git+https://github.com/cktan/tomlc99.git')
+sha256sums=('SKIP'
+ 'SKIP')
prepare() {
- cd "$srcdir/powermate-linux"
+ cd "$_pkgname"
git submodule init
git config submodule.tomlc99.url "$srcdir/tomlc99"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
pkgver() {
- cd "$srcdir/powermate-linux"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ git describe --long --abbrev=7 --tags |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/powermate-linux"
+ cd "$_pkgname"
make
}
package() {
- cd "$srcdir/powermate-linux"
- install -D -m755 powermate "$pkgdir/usr/bin/powermate"
- install -D -m644 60-powermate.rules "$pkgdir/etc/udev/rules.d/60-powermate.rules"
+ cd "$_pkgname"
+ install -Dm0755 -t "$pkgdir/usr/bin/" powermate
+ install -Dm0644 -t "$pkgdir/etc/udev/rules.d/" 60-powermate.rules
}