summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt2018-07-23 19:19:30 +0200
committerStefan Schmidt2018-07-23 19:19:30 +0200
commit26df53c7fbcfd80fc7abf986e76e9cb33a681ac1 (patch)
tree64dc110254f0b062e0f327c3667dcfe0f111fe7e
parent388808557479ac6301d75782baff31926e52ec00 (diff)
downloadaur-26df53c7fbcfd80fc7abf986e76e9cb33a681ac1.tar.gz
Updated to 8.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD96
-rw-r--r--fix-compilation.patch11
3 files changed, 66 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38f578fae841..f8dad3dde9d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = powerpc-linux-gnu-gcc-stage1
pkgdesc = The GNU Compiler Collection. Stage 1 for toolchain building (powerpc-linux-gnu)
- pkgver = 6.1.1
- pkgrel = 4
+ pkgver = 8.1.0
+ pkgrel = 1
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -9,16 +9,18 @@ pkgbase = powerpc-linux-gnu-gcc-stage1
license = LGPL
license = FDL
license = custom
- depends = powerpc-linux-gnu-binutils>=2.26.1-1
+ depends = powerpc-linux-gnu-binutils>=2.30-4
depends = libmpc
depends = zlib
options = !emptydirs
options = !distcc
options = !strip
- source = https://github.com/gcc-mirror/gcc/archive/1bbd3999.tar.gz
- source = http://isl.gforge.inria.fr/isl-0.16.1.tar.bz2
- md5sums = ff2d7ad9a3144299decbdad85dfcb920
- md5sums = ac1f25a0677912952718a51f5bc20f32
+ source = https://ftp.gnu.org/gnu/gcc/gcc-8.1.0/gcc-8.1.0.tar.xz
+ source = http://isl.gforge.inria.fr/isl-0.18.tar.bz2
+ validpgpkeys = F3691687D867B81B51CE07D9BBE43771487328A9
+ validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
+ sha256sums = 1d1866f992626e61349a1ccd0b8d5253816222cdc13390dcfaa74b093aa2b153
+ sha256sums = 6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b
pkgname = powerpc-linux-gnu-gcc-stage1
diff --git a/PKGBUILD b/PKGBUILD
index 25ee9e0cac75..953805a896c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,35 @@
# Contributor: toha257 <toha257@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
-# Maintainer: Tavian Barnes <tavianator@tavianator.com>
+# Contributor: Tavian Barnes <tavianator@tavianator.com>
# Maintainer: Stefan Schmidt <thrimbor.github@gmail.com>
_target="powerpc-linux-gnu"
pkgname=${_target}-gcc-stage1
-pkgver=6.1.1
-_pkgver=6
-_islver=0.16.1
-pkgrel=4
-_commit=1bbd3999
+pkgver=8.1.0
+_majorver=${pkgver:0:1}
+_islver=0.18
+pkgrel=1
pkgdesc="The GNU Compiler Collection. Stage 1 for toolchain building (${_target})"
-arch=('i686' 'x86_64')
-license=('GPL' 'LGPL' 'FDL' 'custom')
-url="http://gcc.gnu.org"
-depends=("${_target}-binutils>=2.26.1-1" 'libmpc' 'zlib')
-options=('!emptydirs' '!distcc' '!strip')
-source=(https://github.com/gcc-mirror/gcc/archive/${_commit}.tar.gz
+arch=(i686 x86_64)
+license=(GPL LGPL FDL custom)
+url='http://gcc.gnu.org'
+depends=("${_target}-binutils>=2.30-4" libmpc zlib)
+options=(!emptydirs !distcc !strip)
+#source=(https://sources.archlinux.org/other/gcc/gcc-${pkgver/+/-}.tar.xz{,.sig}
+source=(https://ftp.gnu.org/gnu/gcc/gcc-$pkgver/gcc-$pkgver.tar.xz
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
-md5sums=('ff2d7ad9a3144299decbdad85dfcb920'
- 'ac1f25a0677912952718a51f5bc20f32')
+sha256sums=('1d1866f992626e61349a1ccd0b8d5253816222cdc13390dcfaa74b093aa2b153'
+ '6b8b0fd7f81d0a957beb3679c81bbb34ccc7568d5682844d8924424a0dadcb1b')
+validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
+ 13975A70E63C361C73AE69EF6EEB81F8981C74C7) # richard.guenther@gmail.com
-prepare() {
- mv gcc-${_commit}* gcc
- cd ${srcdir}
-
- patch -Np0 < "../fix-compilation.patch"
+_svnrev=259195
+_svnurl=svn://gcc.gnu.org/svn/gcc/branches/gcc-${_majorver}-branch
+_libdir=usr/lib/gcc/$CHOST/${pkgver%%+*}
+prepare() {
+ [[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
cd gcc
# link isl for in-tree build
@@ -40,50 +42,66 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- mkdir ${srcdir}/gcc-build
+ mkdir -p "$srcdir/gcc-build"
}
build() {
- cd ${srcdir}/gcc-build
+ cd gcc-build
# using -pipe causes spurious test-suite failures
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=48565
CFLAGS=${CFLAGS/-pipe/}
CXXFLAGS=${CXXFLAGS/-pipe/}
- ${srcdir}/gcc/configure --prefix=/usr \
+ "$srcdir/gcc/configure" --prefix=/usr \
--program-prefix=${_target}- \
--with-local-prefix=/usr/${_target} \
--with-sysroot=/usr/${_target} \
--with-build-sysroot=/usr/${_target} \
--with-as=/usr/bin/${_target}-as \
--with-ld=/usr/bin/${_target}-ld \
- --libdir=/usr/lib --libexecdir=/usr/lib \
- --target=${_target} --host=${CHOST} --build=${CHOST} \
- --disable-nls --with-newlib \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --disable-nls \
+ --with-newlib \
--enable-languages=c,c++ \
- --disable-shared --disable-threads \
- --with-system-zlib --with-isl --enable-__cxa_atexit \
- --disable-libunwind-exceptions --enable-clocale=gnu \
- --disable-libstdcxx-pch --disable-libssp \
- --enable-gnu-unique-object --enable-linker-build-id \
- --disable-lto --disable-plugin --enable-install-libiberty \
- --with-linker-hash-style=gnu --enable-gnu-indirect-function \
- --disable-multilib --disable-werror \
- --enable-checking=release
+ --disable-shared \
+ --disable-threads \
+ --with-system-zlib \
+ --with-isl \
+ --enable-__cxa_atexit \
+ --disable-libunwind-exceptions \
+ --enable-clocale=gnu \
+ --disable-libstdcxx-pch \
+ --disable-libssp \
+ --enable-gnu-unique-object \
+ --enable-linker-build-id \
+ --disable-lto \
+ --disable-plugin \
+ --enable-install-libiberty \
+ --with-linker-hash-style=gnu \
+ --enable-gnu-indirect-function \
+ --disable-multilib \
+ --disable-werror \
+ --enable-checking=release \
+ --enable-default-pie \
+ --enable-default-ssp \
+ --target=${_target} \
+ --host=${CHOST} \
+ --build=${CHOST}
make all-gcc all-target-libgcc
}
package() {
- cd ${srcdir}/gcc-build
+ cd gcc-build
- make DESTDIR=${pkgdir} install-gcc install-target-libgcc
+ make DESTDIR="$pkgdir" install-gcc install-target-libgcc
- rm -rf ${pkgdir}/usr/share
+ rm -rf "$pkgdir/usr/share"
# strip it manually
- strip ${pkgdir}/usr/bin/* 2>/dev/null || true
- find ${pkgdir}/usr/lib -type f -exec /usr/bin/${_target}-strip \
+ strip "$pkgdir/usr/bin/"* 2>/dev/null || true
+ find "$pkgdir/usr/lib" -type f -exec /usr/bin/${_target}-strip \
--strip-unneeded {} \; 2>/dev/null || true
}
diff --git a/fix-compilation.patch b/fix-compilation.patch
deleted file mode 100644
index f42abbd139ff..000000000000
--- a/fix-compilation.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc/gcc/ubsan.c 2018-02-04 21:13:39.853992701 +0100
-+++ gcc/gcc/ubsan.c 2018-02-04 21:12:44.957195790 +0100
-@@ -1469,7 +1469,7 @@
-
- expanded_location xloc = expand_location (loc);
- if (xloc.file == NULL || strncmp (xloc.file, "\1", 2) == 0
-- || xloc.file == '\0' || xloc.file[0] == '\xff'
-+ || xloc.file[0] == '\0' || xloc.file[0] == '\xff'
- || xloc.file[1] == '\xff')
- return false;
-