summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt2018-02-04 21:24:11 +0100
committerStefan Schmidt2018-02-04 21:24:11 +0100
commit388808557479ac6301d75782baff31926e52ec00 (patch)
tree3da3aa4e5efc1976bc22552ca7e36ea44010148f
parent46676a654827dce2088a5c7a08a3207a04f1d642 (diff)
downloadaur-388808557479ac6301d75782baff31926e52ec00.tar.gz
Fixed gcc compilation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fix-compilation.patch11
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e34d082daf5..38f578fae841 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = powerpc-linux-gnu-gcc-stage1
pkgdesc = The GNU Compiler Collection. Stage 1 for toolchain building (powerpc-linux-gnu)
pkgver = 6.1.1
- pkgrel = 3
+ pkgrel = 4
url = http://gcc.gnu.org
arch = i686
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = powerpc-linux-gnu-gcc-stage1
options = !strip
source = https://github.com/gcc-mirror/gcc/archive/1bbd3999.tar.gz
source = http://isl.gforge.inria.fr/isl-0.16.1.tar.bz2
- md5sums = d4c4546f927b2984d66574b1b5cb817e
+ md5sums = ff2d7ad9a3144299decbdad85dfcb920
md5sums = ac1f25a0677912952718a51f5bc20f32
pkgname = powerpc-linux-gnu-gcc-stage1
diff --git a/PKGBUILD b/PKGBUILD
index 940b792c9200..25ee9e0cac75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=${_target}-gcc-stage1
pkgver=6.1.1
_pkgver=6
_islver=0.16.1
-pkgrel=3
+pkgrel=4
_commit=1bbd3999
pkgdesc="The GNU Compiler Collection. Stage 1 for toolchain building (${_target})"
arch=('i686' 'x86_64')
@@ -20,12 +20,16 @@ depends=("${_target}-binutils>=2.26.1-1" 'libmpc' 'zlib')
options=('!emptydirs' '!distcc' '!strip')
source=(https://github.com/gcc-mirror/gcc/archive/${_commit}.tar.gz
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
-md5sums=('d4c4546f927b2984d66574b1b5cb817e'
+md5sums=('ff2d7ad9a3144299decbdad85dfcb920'
'ac1f25a0677912952718a51f5bc20f32')
prepare() {
mv gcc-${_commit}* gcc
- cd ${srcdir}/gcc
+ cd ${srcdir}
+
+ patch -Np0 < "../fix-compilation.patch"
+
+ cd gcc
# link isl for in-tree build
ln -s ../isl-${_islver} isl
diff --git a/fix-compilation.patch b/fix-compilation.patch
new file mode 100644
index 000000000000..f42abbd139ff
--- /dev/null
+++ b/fix-compilation.patch
@@ -0,0 +1,11 @@
+--- gcc/gcc/ubsan.c 2018-02-04 21:13:39.853992701 +0100
++++ gcc/gcc/ubsan.c 2018-02-04 21:12:44.957195790 +0100
+@@ -1469,7 +1469,7 @@
+
+ expanded_location xloc = expand_location (loc);
+ if (xloc.file == NULL || strncmp (xloc.file, "\1", 2) == 0
+- || xloc.file == '\0' || xloc.file[0] == '\xff'
++ || xloc.file[0] == '\0' || xloc.file[0] == '\xff'
+ || xloc.file[1] == '\xff')
+ return false;
+