summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt2018-07-23 19:13:48 +0200
committerStefan Schmidt2018-07-23 19:13:48 +0200
commit2ad617a25d2d802df093d38f9c6049aa52e9c1b4 (patch)
treecd34d91e015052d045c18eb3ae57b6d3bc6e3a05
parentc58af4ba99895af7d600d6c2587013b44d070c15 (diff)
downloadaur-2ad617a25d2d802df093d38f9c6049aa52e9c1b4.tar.gz
Updated to v2.27
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD86
-rw-r--r--bz20338.patch114
-rw-r--r--glibc-1915d6d1.patch.xzbin214744 -> 0 bytes
4 files changed, 176 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c811b173786c..ab8372c8cfa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = powerpc-linux-gnu-glibc
pkgdesc = GNU C Library (powerpc-linux-gnu)
- pkgver = 2.23
- pkgrel = 6
+ pkgver = 2.27
+ pkgrel = 1
url = http://www.gnu.org/software/libc/
arch = any
license = GPL
license = LGPL
- makedepends = powerpc-linux-gnu-gcc-stage2>=6.1.1
+ makedepends = powerpc-linux-gnu-gcc-stage2>=8.1.0-1
makedepends = gperf
- depends = powerpc-linux-gnu-linux-api-headers>=4.5.5
- provides = powerpc-linux-gnu-glibc-headers=2.23
+ depends = powerpc-linux-gnu-linux-api-headers>=4.16.1-1
+ provides = powerpc-linux-gnu-glibc-headers=2.27
provides = powerpc-linux-gnu-eglibc
conflicts = powerpc-linux-gnu-glibc-headers
conflicts = powerpc-linux-gnu-eglibc
@@ -17,13 +17,13 @@ pkgbase = powerpc-linux-gnu-glibc
options = !buildflags
options = !strip
options = staticlibs
- source = http://ftp.gnu.org/gnu/libc/glibc-2.23.tar.xz
- source = http://ftp.gnu.org/gnu/libc/glibc-2.23.tar.xz.sig
- source = glibc-1915d6d1.patch.xz
- validpgpkeys = F37CDAB708E65EA183FD1AF625EF0A436C2A4AFF
- md5sums = 456995968f3acadbed39f5eba31678df
+ source = https://ftp.gnu.org/gnu/glibc/glibc-2.27.tar.xz
+ source = https://ftp.gnu.org/gnu/glibc/glibc-2.27.tar.xz.sig
+ source = bz20338.patch
+ validpgpkeys = 7273542B39962DF7B299931416792B4EA25340F8
+ md5sums = 898cd5656519ffbc3a03fe811dd89e82
md5sums = SKIP
- md5sums = 90fad90d55a4c70d91a79539ed3642e2
+ md5sums = dc0d3ad59aeaaf591b085a77de6e03e9
pkgname = powerpc-linux-gnu-glibc
diff --git a/PKGBUILD b/PKGBUILD
index f22c3ca8355c..f1db6dc9f5f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,64 @@
# Contributor: Alexander 'hatred' Drozdov <adrozdoff@gmail.com>
# Contributor: toha257 <toha257@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor: Tavian Barnes <tavianator@tavianator.com>
# Maintainer: Stefan Schmidt <thrimbor.github@gmail.com>
_target="powerpc-linux-gnu"
pkgname=${_target}-glibc
-pkgver=2.23
-pkgrel=6
-_commit=1915d6d1
+pkgver=2.27
+pkgrel=1
pkgdesc="GNU C Library (${_target})"
arch=('any')
url="http://www.gnu.org/software/libc/"
-license=('GPL' 'LGPL')
-depends=("${_target}-linux-api-headers>=4.5.5")
-makedepends=("${_target}-gcc-stage2>=6.1.1" 'gperf')
+license=(GPL LGPL)
+depends=("${_target}-linux-api-headers>=4.16.1-1")
+makedepends=("${_target}-gcc-stage2>=8.1.0-1" gperf)
provides=("${_target}-glibc-headers=${pkgver}" "${_target}-eglibc")
conflicts=("${_target}-glibc-headers" "${_target}-eglibc")
replaces=("${_target}-glibc-headers")
-options=('!buildflags' '!strip' 'staticlibs')
-source=(http://ftp.gnu.org/gnu/libc/glibc-${pkgver}.tar.xz{,.sig}
- glibc-${_commit}.patch.xz)
-md5sums=('456995968f3acadbed39f5eba31678df'
+options=(!buildflags !strip staticlibs)
+_commit=23158b08a0908f381459f273a984c6fd328363cb
+#source=(git+https://sourceware.org/git/glibc.git#commit=$_commit
+source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz{,.sig}
+ bz20338.patch)
+validpgpkeys=(7273542B39962DF7B299931416792B4EA25340F8) # Carlos O'Donell
+md5sums=('898cd5656519ffbc3a03fe811dd89e82'
'SKIP'
- '90fad90d55a4c70d91a79539ed3642e2')
-validpgpkeys=('F37CDAB708E65EA183FD1AF625EF0A436C2A4AFF') # Carlos O'Donell
+ 'dc0d3ad59aeaaf591b085a77de6e03e9')
prepare() {
- cd glibc-${pkgver}
+ mkdir -p glibc-build
- patch -p1 -i ${srcdir}/glibc-${_commit}.patch
+ [[ -d glibc-$pkgver ]] && ln -s glibc-$pkgver glibc
+ cd glibc
- mkdir ${srcdir}/glibc-build
+ local i; for i in ${source[@]}; do
+ case ${i%::*} in
+ *.patch)
+ msg2 "Applying ${i}"
+ patch -p1 -i "$srcdir/${i}"
+ ;;
+ esac
+ done
}
build() {
+ local _configure_flags=(
+ --prefix=/
+ --with-headers=/usr/${_target}/include
+ --enable-add-ons
+ --enable-bind-now
+ --enable-lock-elision
+ --disable-multi-arch
+ --enable-stack-protector=strong
+ --enable-stackguard-randomization
+ --disable-profile
+ --disable-werror
+ )
+
cd glibc-build
echo "slibdir=/lib" >> configparms
@@ -43,10 +66,8 @@ build() {
echo "sbindir=/bin" >> configparms
echo "rootsbindir=/bin" >> configparms
- # remove hardening options for building libraries
- export CFLAGS="-U_FORTIFY_SOURCE -O2"
- export CPPFLAGS="-U_FORTIFY_SOURCE -O2"
- unset LD_LIBRARY_PATH
+ # remove fortify for building libraries
+ CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
export BUILD_CC=gcc
export CC=${_target}-gcc
@@ -54,18 +75,13 @@ build() {
export AR=${_target}-ar
export RANLIB=${_target}-ranlib
- ../glibc-${pkgver}/configure --prefix=/ \
- --target=${_target} --host=${_target} --build=${CHOST} \
- --libdir=/lib --libexecdir=/lib \
- --with-headers=/usr/${_target}/include \
- --enable-add-ons \
- --enable-obsolete-rpc \
- --enable-kernel=2.6.32 \
- --enable-bind-now --disable-profile \
- --enable-stackguard-randomization \
- --enable-lock-elision \
- --disable-multi-arch \
- --disable-werror
+ "$srcdir/glibc-$pkgver/configure" \
+ --libdir=/lib \
+ --libexecdir=/lib \
+ ${_configure_flags[@]} \
+ --target=${_target} \
+ --host=${_target} \
+ --build=${CHOST}
echo "build-programs=no" >> configparms
make
@@ -74,11 +90,11 @@ build() {
package() {
cd glibc-build
- make install_root=${pkgdir}/usr/${_target} install
+ make install_root="$pkgdir/usr/$_target" install
- mkdir -p ${pkgdir}/usr/${_target}/usr
- ln -s ../{include,lib} ${pkgdir}/usr/${_target}/usr
+ mkdir -p "$pkgdir/usr/$_target/usr"
+ ln -s ../{include,lib} "$pkgdir/usr/$_target/usr"
# Remove unneeded for compilation files
- rm -rf ${pkgdir}/usr/${_target}/{bin,sbin,etc,share,var}
+ rm -rf "$pkgdir/usr/$_target/"{bin,sbin,etc,share,var}
}
diff --git a/bz20338.patch b/bz20338.patch
new file mode 100644
index 000000000000..d223e9f08882
--- /dev/null
+++ b/bz20338.patch
@@ -0,0 +1,114 @@
+From 74250a7cdf106d4ca7d9506e6d5dc7c448dc3434 Mon Sep 17 00:00:00 2001
+From: David Michael <david.michael@coreos.com>
+Date: Thu, 15 Dec 2016 15:22:57 -0800
+Subject: [PATCH] gshadow: Sync fgetsgent_r.c with grp/fgetgrent_r.c
+
+ [BZ #20338]
+ * gshadow/fgetsgent_r.c: Include <libio/iolibio.h>.
+ (flockfile): New macro.
+ (funlockfile): Likewise.
+ (__fgetsgent_r): Sync with __fgetgrent_r.
+ * nss/nss_files/files-sgrp.c: Fix "fgetsgent_r.c" typo.
+---
+ gshadow/fgetsgent_r.c | 35 ++++++++++++++++++++++++-----------
+ nss/nss_files/files-sgrp.c | 2 +-
+ 2 files changed, 25 insertions(+), 12 deletions(-)
+
+diff --git a/gshadow/fgetsgent_r.c b/gshadow/fgetsgent_r.c
+index b70f6fa..02cd33a 100644
+--- a/gshadow/fgetsgent_r.c
++++ b/gshadow/fgetsgent_r.c
+@@ -20,39 +20,44 @@
+ #include <gshadow.h>
+ #include <stdio.h>
+
++#include <libio/iolibio.h>
++#define flockfile(s) _IO_flockfile (s)
++#define funlockfile(s) _IO_funlockfile (s)
++
+ /* Define a line parsing function using the common code
+ used in the nss_files module. */
+
+ #define STRUCTURE sgrp
+ #define ENTNAME sgent
+-#define EXTERN_PARSER 1
++#define EXTERN_PARSER 1
+ struct sgent_data {};
+
+ #include <nss/nss_files/files-parse.c>
+
+
+-/* Read one shadow entry from the given stream. */
++/* Read one entry from the given stream. */
+ int
+ __fgetsgent_r (FILE *stream, struct sgrp *resbuf, char *buffer, size_t buflen,
+ struct sgrp **result)
+ {
+ char *p;
++ int parse_result;
+
+- _IO_flockfile (stream);
++ flockfile (stream);
+ do
+ {
+ buffer[buflen - 1] = '\xff';
+ p = fgets_unlocked (buffer, buflen, stream);
+- if (p == NULL && feof_unlocked (stream))
++ if (__builtin_expect (p == NULL, 0) && feof_unlocked (stream))
+ {
+- _IO_funlockfile (stream);
++ funlockfile (stream);
+ *result = NULL;
+ __set_errno (ENOENT);
+ return errno;
+ }
+- if (p == NULL || buffer[buflen - 1] != '\xff')
++ if (__builtin_expect (p == NULL, 0) || buffer[buflen - 1] != '\xff')
+ {
+- _IO_funlockfile (stream);
++ funlockfile (stream);
+ *result = NULL;
+ __set_errno (ERANGE);
+ return errno;
+@@ -61,13 +66,21 @@ __fgetsgent_r (FILE *stream, struct sgrp *resbuf, char *buffer, size_t buflen,
+ /* Skip leading blanks. */
+ while (isspace (*p))
+ ++p;
+- } while (*p == '\0' || *p == '#' || /* Ignore empty and comment lines. */
++ } while (*p == '\0' || *p == '#' /* Ignore empty and comment lines. */
+ /* Parse the line. If it is invalid, loop to
+ get the next line of the file to parse. */
+- ! parse_line (buffer, (void *) resbuf, (void *) buffer, buflen,
+- &errno));
++ || ! (parse_result = parse_line (p, resbuf,
++ (void *) buffer, buflen,
++ &errno)));
++
++ funlockfile (stream);
+
+- _IO_funlockfile (stream);
++ if (__builtin_expect (parse_result, 0) == -1)
++ {
++ /* The parser ran out of space. */
++ *result = NULL;
++ return errno;
++ }
+
+ *result = resbuf;
+ return 0;
+diff --git a/nss/nss_files/files-sgrp.c b/nss/nss_files/files-sgrp.c
+index 15dc659..05c3805 100644
+--- a/nss/nss_files/files-sgrp.c
++++ b/nss/nss_files/files-sgrp.c
+@@ -23,7 +23,7 @@
+ #define DATABASE "gshadow"
+ struct sgent_data {};
+
+-/* Our parser function is already defined in sgetspent_r.c, so use that
++/* Our parser function is already defined in sgetsgent_r.c, so use that
+ to parse lines from the database file. */
+ #define EXTERN_PARSER
+ #include "files-parse.c"
+--
+2.7.4
+
diff --git a/glibc-1915d6d1.patch.xz b/glibc-1915d6d1.patch.xz
deleted file mode 100644
index 3eefd201662d..000000000000
--- a/glibc-1915d6d1.patch.xz
+++ /dev/null
Binary files differ