summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRikarnto Bariampa2021-11-19 18:59:10 +0200
committerRikarnto Bariampa2021-11-19 18:59:10 +0200
commit141b1afd9e7d1c2448131a00f0be4d3b5d149dba (patch)
tree64c69e37b0063828204de7d495b1d597ffb17de7
parent10a3338a00d9bd98583cc023d2357ff139ea1ad5 (diff)
downloadaur-141b1afd9e7d1c2448131a00f0be4d3b5d149dba.tar.gz
v7.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6e86de76878..a1893bee20e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = powershell
pkgdesc = A cross-platform automation and configuration tool/framework (latest release)
- pkgver = 7.1.5
- pkgrel = 2
+ pkgver = 7.2.0
+ pkgrel = 1
url = https://github.com/PowerShell/PowerShell
install = powershell.install
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
- makedepends = dotnet-sdk>=5.0.9
+ makedepends = dotnet-sdk>=6.0.0
depends = krb5
depends = gcc-libs
depends = glibc
@@ -18,7 +18,7 @@ pkgbase = powershell
depends = icu
options = staticlibs
options = !strip
- source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v7.1.5
+ source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v7.2.0
source = powershell-native::git+https://github.com/PowerShell/PowerShell-Native.git
source = Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a50cbe4e872d..d2006efa97e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
pkgname=powershell
_binaryname=pwsh
-_pkgver=7.1.5
+_pkgver=7.2.0
_pkgnum=${_pkgver:0:1}
pkgver=${_pkgver/-/.}
-pkgrel=2
+pkgrel=1
pkgdesc='A cross-platform automation and configuration tool/framework (latest release)'
arch=('x86_64')
url='https://github.com/PowerShell/PowerShell'
license=('MIT')
-makedepends=('git' 'cmake' 'dotnet-sdk>=5.0.9')
+makedepends=('git' 'cmake' 'dotnet-sdk>=6.0.0')
depends=('krb5' 'gcc-libs' 'glibc' 'lttng-ust' 'zlib' 'openssl-1.0' 'icu')
source=($pkgname::"git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver"
'powershell-native::git+https://github.com/PowerShell/PowerShell-Native.git'
@@ -80,7 +80,7 @@ check() {
package() {
mkdir -pv "$pkgdir/opt/microsoft/$pkgname/$_pkgnum"
- cd "$srcdir/$pkgname/src/powershell-unix/bin/Linux/net5.0/linux-x64/"
+ cd "$srcdir/$pkgname/src/powershell-unix/bin/Linux/net6.0/linux-x64/"
cp -ar ./ "$pkgdir/opt/microsoft/$pkgname/$_pkgnum/"