summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-04-15 22:58:07 +0200
committerCarl Smedstad2023-04-15 23:22:09 +0200
commitbefc92e7aa06744fb6885df6080f178363846b74 (patch)
tree7653199542e45dbe9b9fb47bf489f84b30a94995
parenta0efa12053e262f667b05350f215f291513a30f6 (diff)
downloadaur-befc92e7aa06744fb6885df6080f178363846b74.tar.gz
Publish version 7.3.4-3
I did a namcap scan of the package and given the warnings I fixed the following: * Remove dependencies that are explicitly satisfied via the dotnet-runtime dependency. * Add back openssl-1.1 dependency. This is needed by libmi.so which still seems to be used. See: https://github.com/PowerShell/PowerShell/issues/17193
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16342040c09c..394a648d5783 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
pkgbase = powershell
pkgdesc = A cross-platform automation and configuration tool/framework (latest release)
pkgver = 7.3.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/PowerShell/PowerShell
install = powershell.install
arch = x86_64
license = MIT
makedepends = cmake
- makedepends = dotnet-sdk>=7.0.0
- depends = krb5
- depends = gcc-libs
- depends = glibc
+ makedepends = dotnet-sdk
+ makedepends = patchelf
depends = lttng-ust
- depends = zlib
- depends = openssl
- depends = icu
depends = dotnet-runtime
+ depends = openssl-1.1
options = staticlibs
source = powershell-7.3.4::https://github.com/PowerShell/PowerShell/archive/refs/tags/v7.3.4.tar.gz
source = powershell-native-7.3.2::https://github.com/PowerShell/PowerShell-Native/archive/refs/tags/v7.3.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index be266fab340c..68efa171a818 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@ pkgname=powershell
_binaryname=pwsh
pkgver=7.3.4
_pkgnum=${pkgver:0:1}
-pkgrel=2
+pkgrel=3
pkgdesc='A cross-platform automation and configuration tool/framework (latest release)'
arch=('x86_64')
url='https://github.com/PowerShell/PowerShell'
license=('MIT')
-makedepends=('cmake' 'dotnet-sdk>=7.0.0')
-depends=('krb5' 'gcc-libs' 'glibc' 'lttng-ust' 'zlib' 'openssl' 'icu' 'dotnet-runtime')
+makedepends=('cmake' 'dotnet-sdk' 'patchelf')
+depends=('lttng-ust' 'dotnet-runtime' 'openssl-1.1')
_googletest_commit_hash=4e4df226fc197c0dda6e37f5c8c3845ca1e73a49
_powershell_native_version=7.3.2
@@ -84,6 +84,10 @@ build() {
## Build powershell core
dotnet publish --no-self-contained --configuration Linux "src/powershell-unix/" --output bin --runtime "linux-x64"
+
+ file=src/powershell-unix/bin/Linux/net7.0/linux-x64/libmi.so
+ patchelf --replace-needed libcrypto.so.1.0.0 libcrypto.so.1.1 "$file"
+ patchelf --replace-needed libssl.so.1.0.0 libssl.so.1.1 "$file"
}
check() {