summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2018-06-13 13:03:15 -0400
committerKyle Sferrazza2018-06-13 13:03:15 -0400
commitc741e731328a5bb8a9f4bf008e64208481782483 (patch)
tree58e372f55fddf8b21ab12d62796ea08983928d34
parenteda1670f119ae42539e4aa2a096c2ed7527aa2be (diff)
downloadaur-c741e731328a5bb8a9f4bf008e64208481782483.tar.gz
works with 2.1.300
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xbuild.sh16
-rw-r--r--dotnet-version.patch2
4 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad8d7099eb78..a5b08833e683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = powershell
pkgdesc = A cross-platform automation and configuration tool/framework (latest release)
pkgver = 6.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/PowerShell/PowerShell
install = powershell.install
arch = x86_64
@@ -18,8 +18,8 @@ pkgbase = powershell
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = a0d7e3fa753f74e9722f71a5ab3da6d9
- md5sums = 7fc09756121a31bc336498a18edfe6da
+ md5sums = 477e7fe74b41d814da19ec23db3e620f
+ md5sums = 835214e5782a09d6be7796d9da3d42f6
pkgname = powershell
diff --git a/PKGBUILD b/PKGBUILD
index 703a633b350d..31368cdbbc54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=powershell
binaryname=pwsh
_pkgver=6.0.2
pkgver=${_pkgver/-/.}
-pkgrel=2
+pkgrel=3
pkgdesc='A cross-platform automation and configuration tool/framework (latest release)'
arch=('x86_64')
url='https://github.com/PowerShell/PowerShell'
@@ -20,8 +20,8 @@ source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'a0d7e3fa753f74e9722f71a5ab3da6d9'
- '7fc09756121a31bc336498a18edfe6da')
+ '477e7fe74b41d814da19ec23db3e620f'
+ '835214e5782a09d6be7796d9da3d42f6')
install=powershell.install
prepare() {
diff --git a/build.sh b/build.sh
index 7ac578d797fa..3b3b9bb66efc 100755
--- a/build.sh
+++ b/build.sh
@@ -9,16 +9,16 @@ dotnet restore src/ResGen
dotnet restore src/TypeCatalogGen
## Setup the build target to gather dependency information
-targetFile="$(pwd)/src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
+targetFile="src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
cat > $targetFile <<-"EOF"
<Project>
- <Target Name="_GetDependencies"
- DependsOnTargets="ResolveAssemblyReferencesDesignTime">
- <ItemGroup>
- <_RefAssemblyPath Include="%(_ReferencesFromRAR.ResolvedPath)%3B" Condition=" '%(_ReferencesFromRAR.Type)' == 'assembly' And '%(_ReferencesFromRAR.PackageName)' != 'Microsoft.Management.Infrastructure' " />
- </ItemGroup>
- <WriteLinesToFile File="$(_DependencyFile)" Lines="@(_RefAssemblyPath)" Overwrite="true" />
- </Target>
+ <Target Name="_GetDependencies"
+ DependsOnTargets="ResolveAssemblyReferencesDesignTime">
+ <ItemGroup>
+ <_RefAssemblyPath Include="%(_ReferencesFromRAR.HintPath)%3B" Condition=" '%(_ReferencesFromRAR.NuGetPackageId)' != 'Microsoft.Management.Infrastructure' "/>
+ </ItemGroup>
+ <WriteLinesToFile File="$(_DependencyFile)" Lines="@(_RefAssemblyPath)" Overwrite="true" />
+ </Target>
</Project>
EOF
dotnet msbuild src/Microsoft.PowerShell.SDK/Microsoft.PowerShell.SDK.csproj /t:_GetDependencies "/property:DesignTimeBuild=true;_DependencyFile=$(pwd)/src/TypeCatalogGen/powershell.inc" /nologo
diff --git a/dotnet-version.patch b/dotnet-version.patch
index 2d71bff05d23..5d5aa5fd0fa6 100644
--- a/dotnet-version.patch
+++ b/dotnet-version.patch
@@ -4,6 +4,6 @@
{
"sdk": {
- "version": "2.0.2"
-+ "version": "2.1.3"
++ "version": "2.1.300"
}
}