summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2017-10-06 22:56:41 -0400
committerKyle Sferrazza2017-10-06 22:56:41 -0400
commit335f5ddb54a7aa962b731b20d5f30639de230e3b (patch)
treeca6f68b8e03e826e187af036d128a63dfbe117ff
parent5412351b51281a86a9c6b6fa50275a5d841de8e4 (diff)
downloadaur-335f5ddb54a7aa962b731b20d5f30639de230e3b.tar.gz
beta 8
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bc4c889566..b73e3f9028f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
pkgbase = powershell-bin
pkgdesc = A cross-platform automation and configuration tool/framework (binary package)
- pkgver = 6.0.0.beta.7
+ pkgver = 6.0.0.beta.8
pkgrel = 1
url = https://github.com/Powershell/Powershell
install = powershell.install
arch = x86_64
license = MIT
- makedepends = rsync
- depends = libunwind
- depends = icu55
- depends = libcurl-openssl-1.0
provides = powershell
conflicts = powershell
options = staticlibs
options = !strip
- source = https://github.com/PowerShell/PowerShell/releases/download/v6.0.0-beta.7/powershell_6.0.0-beta.7-1ubuntu1.16.04.1_amd64.deb
- md5sums = 725a93bb5cc730abbf1d1d301c82abba
+ source = https://github.com/PowerShell/PowerShell/releases/download/v6.0.0-beta.8/powershell_6.0.0-beta.8-1.ubuntu.17.04_amd64.deb
+ md5sums = dd698384f5a0f9cd3ce7dd8dd85cbb92
pkgname = powershell-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5e8551ff6f4..b55e24e6aae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Tomasz Hamerla <tomasz.hamerla@outlook.com>
pkgname=powershell-bin
-_pkgver=6.0.0-beta.7
+_pkgver=6.0.0-beta.8
pkgver=${_pkgver/-/.}
pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework (binary package)"
@@ -12,13 +12,9 @@ license=('MIT')
provides=('powershell')
conflicts=('powershell')
options=(staticlibs !strip)
-depends=('libunwind' 'icu55' 'libcurl-openssl-1.0')
-makedepends=('rsync')
install=powershell.install
-
-md5sums=('725a93bb5cc730abbf1d1d301c82abba')
-
-source=("https://github.com/PowerShell/PowerShell/releases/download/v${_pkgver}/powershell_${_pkgver}-1ubuntu1.16.04.1_amd64.deb")
+md5sums=('dd698384f5a0f9cd3ce7dd8dd85cbb92')
+source=("https://github.com/PowerShell/PowerShell/releases/download/v${_pkgver}/powershell_${_pkgver}-1.ubuntu.17.04_amd64.deb")
package() {
bsdtar xf data.tar.gz
@@ -28,7 +24,7 @@ package() {
# Fix man path
cd "${pkgdir}"
- rsync --recursive usr/local/share usr
+ cp -r usr/local/share usr
rm -rf usr/local
# Force powershell to load appropriate libs
@@ -38,7 +34,5 @@ package() {
#!/bin/sh
LD_PRELOAD='/usr/lib/libcurl-openssl-1.0.so /usr/lib/openssl-1.0-compat/libssl.so /usr/lib/openssl-1.0-compat/libcrypto.so' exec lnbin.powershell "\$@" 2>/dev/null
EOF
- # Fix script permissions
chmod 755 powershell
-
}