summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2018-11-16 15:19:58 -0500
committerKyle Sferrazza2018-11-16 15:19:58 -0500
commit38c350b438a028bc48e8e073d299e5bfb53d19ee (patch)
tree722f241277298d1c1e5ae05cd96f566c2007fcb1
parent765486151f9f3bbc1dedb42e1cd43783cf94dc5c (diff)
downloadaur-38c350b438a028bc48e8e073d299e5bfb53d19ee.tar.gz
dotnet-version.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--dotnet-version.patch9
3 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8bd8d8db9e2..c37eb30551a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powershell-git
pkgdesc = A cross-platform automation and configuration tool/framework (git version)
- pkgver = 6.2.0.preview.1.54.g5d06fba36
+ pkgver = 6.2.0.preview.2.10.gdedddb6b5
pkgrel = 1
url = https://github.com/PowerShell/PowerShell
install = powershell.install
@@ -19,10 +19,12 @@ pkgbase = powershell-git
source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
source = googletest::git+https://github.com/google/googletest.git
source = build.sh
+ source = dotnet-version.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = 70d89b489a4ae0198b9f8dbeb7bb9c40
+ md5sums = 17cf304cc89b323ea2a8c97de83267b2
pkgname = powershell-git
diff --git a/PKGBUILD b/PKGBUILD
index 6f06d184751a..bb4288c424e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='powershell-git'
_pkgname='powershell'
_binaryname='pwsh'
-pkgver=6.2.0.preview.1.54.g5d06fba36
+pkgver=6.2.0.preview.2.10.gdedddb6b5
pkgrel=1
pkgdesc='A cross-platform automation and configuration tool/framework (git version)'
arch=('x86_64')
@@ -14,13 +14,15 @@ depends=('icu' 'libunwind' 'openssl-1.0')
provides=('powershell')
conflicts=('powershell')
source=($_pkgname::'git+https://github.com/PowerShell/PowerShell.git'
-'pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop'
-'googletest::git+https://github.com/google/googletest.git'
-build.sh)
+ 'pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop'
+ 'googletest::git+https://github.com/google/googletest.git'
+ build.sh
+ 'dotnet-version.patch')
md5sums=('SKIP'
'SKIP'
'SKIP'
- '70d89b489a4ae0198b9f8dbeb7bb9c40')
+ '70d89b489a4ae0198b9f8dbeb7bb9c40'
+ '17cf304cc89b323ea2a8c97de83267b2')
install=powershell.install
pkgver() {
@@ -35,6 +37,8 @@ prepare() {
git config submodule.src/libpsl-native/test/googletest.url "$srcdir"/googletest
git submodule update
git clean -dfx
+
+ cat $srcdir/dotnet-version.patch | patch -p1
}
build() {
diff --git a/dotnet-version.patch b/dotnet-version.patch
new file mode 100644
index 000000000000..4c65a5d10f66
--- /dev/null
+++ b/dotnet-version.patch
@@ -0,0 +1,9 @@
+--- a/global.json
++++ b/global.json
+@@ -1,5 +1,5 @@
+ {
+ "sdk": {
+- "version": "2.1.403"
++ "version": "2.1.500"
+ }
+ }