summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2016-09-28 19:07:12 -0400
committerSergio Correia2016-09-28 19:07:12 -0400
commit6aa31d183c3a0f0c7c9d2a08ed8a05aa1d70e7da (patch)
tree68cea5c2d73ed20123ee6fe5ac9a33723bbcd24e
parent33cf3a71a3ead135c37e4b8edd5eb24da3d9e83f (diff)
downloadaur-6aa31d183c3a0f0c7c9d2a08ed8a05aa1d70e7da.tar.gz
Follow the AUR git submodule guidelines
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c310d02ff03b..d40bfbcab072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powershell-git
pkgdesc = A cross-platform automation and configuration tool/framework.
- pkgver = 6.0.0.alpha.10.71.gd32bf23
+ pkgver = 6.0.0.alpha.10.73.g0c9abbc
pkgrel = 1
url = https://github.com/PowerShell/PowerShell
arch = x86_64
@@ -15,10 +15,14 @@ pkgbase = powershell-git
conflicts = powershell
conflicts = powershell-bin
source = powershell::git+https://github.com/PowerShell/PowerShell.git
+ source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
+ source = googletest::git+https://github.com/google/googletest.git
source = os-release
source = revert-commit-c695d41.patch
source = build.sh
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = e903a41166648f2e6113dff83b116e9ed6a5dc7d302ac24ae26811583bcb9cc2
sha256sums = 4568c69cf2a0a961d3f16c069b24391dea7898cd7c856cad94b70a73ef6a9224
sha256sums = 190dfc2b3b0bbc49db8411c3b934f460cf9d1399e30e93a5ff50e9b33613428b
diff --git a/PKGBUILD b/PKGBUILD
index 3fe265378979..d38d7a1b2947 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='powershell-git'
_pkgname='powershell'
-pkgver=6.0.0.alpha.10.71.gd32bf23
+pkgver=6.0.0.alpha.10.73.g0c9abbc
pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework."
arch=('x86_64')
@@ -13,10 +13,14 @@ depends=('bash' 'icu55')
conflicts=('powershell' 'powershell-bin')
provides=('powershell')
source=($_pkgname::'git+https://github.com/PowerShell/PowerShell.git'
+ 'pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop'
+ 'googletest::git+https://github.com/google/googletest.git'
'os-release'
'revert-commit-c695d41.patch'
'build.sh')
sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
'e903a41166648f2e6113dff83b116e9ed6a5dc7d302ac24ae26811583bcb9cc2'
'4568c69cf2a0a961d3f16c069b24391dea7898cd7c856cad94b70a73ef6a9224'
'190dfc2b3b0bbc49db8411c3b934f460cf9d1399e30e93a5ff50e9b33613428b')
@@ -28,7 +32,10 @@ pkgver() {
prepare() {
cd "${_pkgname}"
- git submodule update --init
+ git submodule init
+ git config submodule.src/Modules/Pester.url "${srcdir}/pester"
+ git config submodule.src/libpsl-native/test/googletest.url "${srcdir}/googletest"
+ git submodule update
# Starting off clean.
git clean -dfx