summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2017-08-21 21:25:59 -0400
committerKyle Sferrazza2017-08-21 21:25:59 -0400
commit9d658bd34e8dbb95557091ae517b92509bdffdd1 (patch)
tree8e700dfccc2b789df7d28cb3b1b2f22f87461f83
parentcc5b2a93520c36c05489385359d9159c32c7ad59 (diff)
downloadaur-9d658bd34e8dbb95557091ae517b92509bdffdd1.tar.gz
now properly builds powershell without the git version of dotnet, and adds powershell to /etc/shells
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD30
-rw-r--r--os-release9
-rw-r--r--powershell.install11
4 files changed, 25 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62878f851abd..441e9d5438ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,23 +3,20 @@ pkgbase = powershell-git
pkgver = 6.0.0.beta.2.14.gf04d2fd2
pkgrel = 1
url = https://github.com/PowerShell/PowerShell
+ install = powershell.install
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
- makedepends = proot
- makedepends = dotnet-cli-git
+ makedepends = dotnet-sdk-2.0
depends = icu
provides = powershell
- conflicts = powershell
source = powershell::git+https://github.com/PowerShell/PowerShell.git
source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
source = googletest::git+https://github.com/google/googletest.git
- source = os-release
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = f5841baa62b1322c07f9394940cec818
pkgname = powershell-git
diff --git a/PKGBUILD b/PKGBUILD
index ac036dda3f44..9f2528ccb383 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,22 @@
pkgname='powershell-git'
_pkgname='powershell'
-pkgver=6.0.0.beta.2.14.gf04d2fd2
+pkgver=6.0.0.beta.5.78.gcdbbb7a4b
pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework (git version)"
arch=('x86_64')
url="https://github.com/PowerShell/PowerShell"
license=('MIT')
-makedepends=('git' 'cmake' 'proot' 'dotnet-cli-git')
+makedepends=('git' 'cmake' 'dotnet-sdk-2.0')
depends=('icu')
provides=('powershell')
-conflicts=('powershell')
source=($_pkgname::'git+https://github.com/PowerShell/PowerShell.git'
'pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop'
- 'googletest::git+https://github.com/google/googletest.git'
- 'os-release')
+ 'googletest::git+https://github.com/google/googletest.git')
md5sums=('SKIP'
'SKIP'
- 'SKIP'
- 'f5841baa62b1322c07f9394940cec818')
+ 'SKIP')
+install=powershell.install
pkgver() {
cd $_pkgname
@@ -33,9 +31,9 @@ prepare() {
git config submodule.src/Modules/Pester.url "$srcdir"/pester
git config submodule.src/libpsl-native/test/googletest.url "$srcdir"/googletest
git submodule update
-
- # Starting off clean.
git clean -dfx
+
+ sed -i -e 's/hash powershell/\/bin\/false/g' build.sh
}
build() {
@@ -43,18 +41,14 @@ build() {
pushd src/libpsl-native
cmake .
- make
+ make -j
popd
- PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/powershell/build.sh
+ "$srcdir"/powershell/build.sh
}
check() {
cd $_pkgname/src/libpsl-native
-
- PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release \
make test
}
@@ -63,12 +57,12 @@ package() {
cd $_pkgname/src/powershell-unix
mkdir -p "$pkgdir"/usr/lib/$_pkgname
- cp -a bin/Linux/netcoreapp*/ubuntu.16.04-x64 "$pkgdir"/usr/lib/$_pkgname
- chmod 755 "$pkgdir"/usr/lib/$_pkgname/ubuntu.16.04-x64/$_pkgname
+ cp -a bin/Linux/netcoreapp*/linux-x64 "$pkgdir"/usr/lib/$_pkgname
+ chmod 755 "$pkgdir"/usr/lib/$_pkgname/linux-x64/$_pkgname
mkdir -p "$pkgdir"/usr/share/licenses/$_pkgname
cp ../../LICENSE.txt "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
mkdir -p "$pkgdir"/usr/bin
- ln -s /usr/lib/$_pkgname/ubuntu.16.04-x64/$_pkgname "$pkgdir"/usr/bin/powershell
+ ln -s /usr/lib/$_pkgname/linux-x64/$_pkgname "$pkgdir"/usr/bin/powershell
}
diff --git a/os-release b/os-release
deleted file mode 100644
index 5cff123fce0a..000000000000
--- a/os-release
+++ /dev/null
@@ -1,9 +0,0 @@
-NAME="Ubuntu"
-VERSION="16.04.1 LTS"
-ID=ubuntu
-ID_LIKE=debian
-PRETTY_NAME="Ubuntu 16.04.1 LTS"
-VERSION_ID="16.04"
-HOME_URL="http://www.ubuntu.com/"
-SUPPORT_URL="http://help.ubuntu.com/"
-BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/" \ No newline at end of file
diff --git a/powershell.install b/powershell.install
new file mode 100644
index 000000000000..53cc793aab94
--- /dev/null
+++ b/powershell.install
@@ -0,0 +1,11 @@
+post_install() {
+ grep -qe '^/usr/bin/powershell$' etc/shells || echo '/usr/bin/powershell' >> etc/shells
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ sed -ri '\|^/usr/bin/powershell$|d' etc/shells
+}