summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2017-10-06 22:47:01 -0400
committerKyle Sferrazza2017-10-06 22:47:01 -0400
commita302f9a149bfa46f7f5f30d57b9d67bed1e25cba (patch)
tree81c9297b4aa1aca309cac3d828c91f1213190420
parent21a1356c760062a14b705d14b1c977ad6889def0 (diff)
downloadaur-a302f9a149bfa46f7f5f30d57b9d67bed1e25cba.tar.gz
beta 8 fixes
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
-rwxr-xr-xbuild.sh83
4 files changed, 42 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e317e947da8..2b7450f324b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powershell-git
pkgdesc = A cross-platform automation and configuration tool/framework (git version)
- pkgver = 6.0.0.beta.7.17.g03e3257b0
+ pkgver = 6.0.0.beta.8.16.g5cec92294
pkgrel = 1
url = https://github.com/PowerShell/PowerShell
install = powershell.install
@@ -19,7 +19,7 @@ pkgbase = powershell-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = ae733aaf023f7d07e6ed9e8fffcd8ff1
+ md5sums = 4c096f1ce88fd387c9ec81f7ac0581ea
pkgname = powershell-git
diff --git a/.gitignore b/.gitignore
index 3f598c7740dd..190df19fe008 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,6 @@ googletest/
pester/
pkg/
*.xz
+*.gz
powershell/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 572424d9d895..1fd34338fd16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='powershell-git'
_pkgname='powershell'
-pkgver=6.0.0.beta.7.17.g03e3257b0
+pkgver=6.0.0.beta.8.16.g5cec92294
pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework (git version)"
arch=('x86_64')
@@ -19,12 +19,11 @@ source=($_pkgname::'git+https://github.com/PowerShell/PowerShell.git'
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'ae733aaf023f7d07e6ed9e8fffcd8ff1')
+ '4c096f1ce88fd387c9ec81f7ac0581ea')
install=powershell.install
pkgver() {
cd $_pkgname
-
git describe --tags --long | sed 's/^v//;s/-/./;s/-/./g'
}
@@ -41,12 +40,6 @@ prepare() {
build() {
cd $_pkgname
-
- pushd src/libpsl-native
- cmake .
- make -j
- popd
-
"$srcdir"/build.sh
}
@@ -55,7 +48,6 @@ check() {
make test
}
-
package() {
cd $_pkgname/src/powershell-unix
diff --git a/build.sh b/build.sh
index 33c4d7452cc7..c49ae5bed854 100755
--- a/build.sh
+++ b/build.sh
@@ -1,20 +1,14 @@
#!/usr/bin/env bash
set -e
-if hash powershell 2>/dev/null; then
- echo 'Continuing with `powershell -noprofile -c Start-PSBuild`'
- powershell -noprofile -c "Import-Module ./build.psm1; Start-PSBuild"
-else
- echo 'Continuing with full manual build'
-
- ## Restore
- dotnet restore src/powershell-unix
- dotnet restore src/ResGen
- dotnet restore src/TypeCatalogGen
-
- ## Setup the build target to gather dependency information
- targetFile="$(pwd)/src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
- cat > $targetFile <<-"EOF"
+## Restore
+dotnet restore src/powershell-unix
+dotnet restore src/ResGen
+dotnet restore src/TypeCatalogGen
+
+## Setup the build target to gather dependency information
+targetFile="$(pwd)/src/Microsoft.PowerShell.SDK/obj/Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets"
+cat > $targetFile <<-"EOF"
<Project>
<Target Name="_GetDependencies"
DependsOnTargets="ResolveAssemblyReferencesDesignTime">
@@ -25,35 +19,32 @@ else
</Target>
</Project>
EOF
- dotnet msbuild src/Microsoft.PowerShell.SDK/Microsoft.PowerShell.SDK.csproj /t:_GetDependencies "/property:DesignTimeBuild=true;_DependencyFile=$(pwd)/src/TypeCatalogGen/powershell.inc" /nologo
-
- ## Generate 'powershell.version'
- git --git-dir="$(pwd)/.git" describe --dirty --abbrev=60 > "$(pwd)/powershell.version"
-
- ## create the telemetry flag file
- touch "$(pwd)/DELETE_ME_TO_DISABLE_CONSOLEHOST_TELEMETRY"
-
- ## Generate resource binding C# files
- pushd src/ResGen
- dotnet run
- popd
-
- ## Generate 'CorePsTypeCatalog.cs'
- pushd src/TypeCatalogGen
- dotnet run ../Microsoft.PowerShell.CoreCLR.AssemblyLoadContext/CorePsTypeCatalog.cs powershell.inc
- popd
-
- ## Build native component
- pushd src/libpsl-native
- cmake -DCMAKE_BUILD_TYPE=Debug .
- make -j
- make test
- popd
-
- ## Build powershell core
- rawRid="$(dotnet --info | grep RID)"
- rid=${rawRid##* } # retain the part after the last space
- dotnet publish --configuration Linux src/powershell-unix/ --output bin --runtime $rid
-
- echo 'You can run powershell from bin/, but some modules that are normally added by the Restore-PSModule step will not be available.'
-fi
+dotnet msbuild src/Microsoft.PowerShell.SDK/Microsoft.PowerShell.SDK.csproj /t:_GetDependencies "/property:DesignTimeBuild=true;_DependencyFile=$(pwd)/src/TypeCatalogGen/powershell.inc" /nologo
+
+## Generate 'powershell.version'
+git --git-dir="$(pwd)/.git" describe --dirty --abbrev=60 > "$(pwd)/powershell.version"
+
+## create the telemetry flag file
+touch "$(pwd)/DELETE_ME_TO_DISABLE_CONSOLEHOST_TELEMETRY"
+
+## Generate resource binding C# files
+pushd src/ResGen
+dotnet run
+popd
+
+## Generate 'CorePsTypeCatalog.cs'
+pushd src/TypeCatalogGen
+dotnet run ../System.Management.Automation/CoreCLR/CorePsTypeCatalog.cs powershell.inc
+popd
+
+## Build native component
+pushd src/libpsl-native
+cmake -DCMAKE_BUILD_TYPE=Debug .
+make -j
+make test
+popd
+
+## Build powershell core
+rawRid="$(dotnet --info | grep RID)"
+rid=${rawRid##* } # retain the part after the last space
+dotnet publish --configuration Linux src/powershell-unix/ --output bin --runtime $rid