summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoïc Guitaut2015-06-28 23:33:20 +0200
committerLoïc Guitaut2015-06-28 23:33:20 +0200
commit31616cef66b7eace242acfd80e3421cc02f12a4a (patch)
tree01776206ada667def21a4e872c42e879f79fcfc6
downloadaur-31616cef66b7eace242acfd80e3421cc02f12a4a.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD35
-rw-r--r--ppcoin-qt.desktop12
-rw-r--r--ppcoin-qt.install11
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f39d2153111
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = ppcoin-qt
+ pkgdesc = P2P Long-Term Energy-Efficient Crypto-Currency (QT)
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://www.ppcoin.org/
+ install = ppcoin-qt.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = automoc4
+ makedepends = qrencode
+ makedepends = miniupnpc
+ depends = boost-libs
+ depends = qt4
+ depends = miniupnpc
+ depends = qrencode
+ source = http://downloads.sourceforge.net/project/ppcoin/0.4.0/ppcoin-0.4.0-linux.tar.gz
+ source = ppcoin-qt.desktop
+ sha256sums = 561076e8d4e82085d577eb717b9f8b52571556fea2b8181fa8eb6039218d3f06
+ sha256sums = c770adf5f0dcb0394a3258014d38bb62d29e49ef9f284709d1578b8b45833df5
+
+pkgname = ppcoin-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7373fe8a638
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Loïc Guitaut <flink at belfalas dot eu>
+
+pkgname='ppcoin-qt'
+pkgver=0.4.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.ppcoin.org/"
+makedepends=('boost' 'automoc4' 'qrencode' 'miniupnpc')
+license=('MIT')
+pkgdesc="P2P Long-Term Energy-Efficient Crypto-Currency (QT)"
+depends=(boost-libs qt4 miniupnpc qrencode)
+install=ppcoin-qt.install
+source=("http://downloads.sourceforge.net/project/ppcoin/0.4.0/ppcoin-0.4.0-linux.tar.gz"
+ "$pkgname.desktop")
+sha256sums=('561076e8d4e82085d577eb717b9f8b52571556fea2b8181fa8eb6039218d3f06'
+ 'c770adf5f0dcb0394a3258014d38bb62d29e49ef9f284709d1578b8b45833df5')
+
+build() {
+ cd "$srcdir/ppcoin-$pkgver-linux/src"
+
+ # and make qt gui
+ qmake-qt4 USE_QRCODE=1 USE_UPNP=1
+ make
+}
+
+
+package() {
+ install -Dm644 ppcoin-qt.desktop "$pkgdir"/usr/share/applications/ppcoin.desktop
+ cd "$srcdir/ppcoin-$pkgver-linux/src"
+ install -Dm755 ppcoin-qt "$pkgdir"/usr/bin/ppcoin-qt
+ install -Dm644 src/qt/res/icons/ppcoin.png "$pkgdir"/usr/share/pixmaps/ppcoin256.png
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
diff --git a/ppcoin-qt.desktop b/ppcoin-qt.desktop
new file mode 100644
index 000000000000..615b044c01bc
--- /dev/null
+++ b/ppcoin-qt.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=PPCoin
+Comment=PPCoin P2P Cryptocurrency
+Comment[fr]=PPCoin, monnaie virtuelle cryptographique pair à pair
+Comment[tr]=PPCoin, eşten eşe kriptografik sanal para birimi
+Exec=/usr/bin/ppcoin-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/ppcoin256.png
+MimeType=x-scheme-handler/ppcoin;
+Categories=Office;
diff --git a/ppcoin-qt.install b/ppcoin-qt.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/ppcoin-qt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}