summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney le Clément de Saint-Marcq2013-04-05 13:54:04 +0200
committerVianney le Clément de Saint-Marcq2015-06-11 20:38:43 +0200
commita1f363040b0dcb08ca453fdf167bc4fc9b2c40b4 (patch)
treeb99cd6ac6da64db48a6cf9743c6d8ce09994cf71
parente49d437fb15b48d5c7fda476cb39bdca7126d5ca (diff)
downloadaur-a1f363040b0dcb08ca453fdf167bc4fc9b2c40b4.tar.gz
Update for VCS support in pacman 4.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD37
2 files changed, 17 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd868f9cd994..d396ab969d3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pplatex-git
pkgdesc = Pretty-Print LaTeX: A tool to reformat the output of latex and friends into readable messages
- pkgver = 20121105
+ pkgver = 20120905.g9f37707
pkgrel = 1
url = https://github.com/stefanhepp/pplatex
arch = i686
@@ -10,6 +10,8 @@ pkgbase = pplatex-git
makedepends = scons
depends = pcre
depends = texlive-bin
+ source = git://github.com/stefanhepp/pplatex.git
+ md5sums = SKIP
pkgname = pplatex-git
diff --git a/PKGBUILD b/PKGBUILD
index f164015e7943..8302900fd732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Vianney le Clément <vleclement AT gmail·com>
-pkgname=pplatex-git
-pkgver=20121105
+_pkgname=pplatex
+pkgname=$_pkgname-git
+pkgver=20120905.g9f37707
pkgrel=1
pkgdesc="Pretty-Print LaTeX: A tool to reformat the output of latex and friends into readable messages"
arch=('i686' 'x86_64')
@@ -8,33 +9,23 @@ url="https://github.com/stefanhepp/pplatex"
license=('GPL3')
depends=('pcre' 'texlive-bin')
makedepends=('git' 'scons')
-
-_gitroot=https://github.com/stefanhepp/pplatex.git
-_gitname=pplatex
+source=("git://github.com/stefanhepp/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ _date=$(git show -s --format='%ci' | cut -d' ' -f1 | sed 's/-//g')
+ _hash=$(git show -s --format='%h')
+ echo "$_date.g$_hash"
+}
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
+ cd "$srcdir/$_pkgname"
scons
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir/$_pkgname"
install -Dm755 bin/pplatex "$pkgdir/usr/bin/pplatex"
ln -s pplatex "$pkgdir/usr/bin/ppdflatex"
}