summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVianney le Clément de Saint-Marcq2012-11-05 14:16:38 +0100
committerVianney le Clément de Saint-Marcq2015-06-11 20:38:41 +0200
commite49d437fb15b48d5c7fda476cb39bdca7126d5ca (patch)
tree732914fd079268ae03d0193765a3e8349e836061
downloadaur-e49d437fb15b48d5c7fda476cb39bdca7126d5ca.tar.gz
New package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd868f9cd994
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pplatex-git
+ pkgdesc = Pretty-Print LaTeX: A tool to reformat the output of latex and friends into readable messages
+ pkgver = 20121105
+ pkgrel = 1
+ url = https://github.com/stefanhepp/pplatex
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = scons
+ depends = pcre
+ depends = texlive-bin
+
+pkgname = pplatex-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f164015e7943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Vianney le Clément <vleclement AT gmail·com>
+pkgname=pplatex-git
+pkgver=20121105
+pkgrel=1
+pkgdesc="Pretty-Print LaTeX: A tool to reformat the output of latex and friends into readable messages"
+arch=('i686' 'x86_64')
+url="https://github.com/stefanhepp/pplatex"
+license=('GPL3')
+depends=('pcre' 'texlive-bin')
+makedepends=('git' 'scons')
+
+_gitroot=https://github.com/stefanhepp/pplatex.git
+_gitname=pplatex
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ scons
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ install -Dm755 bin/pplatex "$pkgdir/usr/bin/pplatex"
+ ln -s pplatex "$pkgdir/usr/bin/ppdflatex"
+}
+
+# vim:set ts=2 sw=2 et: