summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-04-20 18:24:11 +0300
committerStelios Tsampas2023-04-20 19:03:42 +0300
commit4a4ae400ae255a0e91de891b4776b98742a07d3d (patch)
tree3e94b53172465da88f81be3b916ea04180dfc16f
parent340e27dda803b618aec8a2e52f96b023b554ec6e (diff)
downloadaur-4a4ae400ae255a0e91de891b4776b98742a07d3d.tar.gz
[ppsspp-git] Update PKGBUILD
-rw-r--r--.SRCINFO103
-rw-r--r--PKGBUILD198
-rw-r--r--PKGBUILD.testing179
-rw-r--r--ppsspp-qt.desktop2
-rw-r--r--ppsspp-sdl.desktop (renamed from ppsspp.desktop)4
5 files changed, 304 insertions, 182 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4776d81ffaaa..da3ed1e82cdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,91 +1,70 @@
pkgbase = ppsspp-git
pkgdesc = A PSP emulator written in C++
- pkgver = 1.13.2.r1362.b7f79dd8b
+ pkgver = 1.14.4.r1397.baa066c7b7
pkgrel = 1
- url = http://www.ppsspp.org/
+ url = https://www.ppsspp.org/
arch = x86_64
license = GPL2
+ makedepends = clang
+ makedepends = lld
makedepends = cmake
makedepends = git
+ makedepends = glew
+ makedepends = glu
makedepends = libglvnd
makedepends = libzip
+ makedepends = ninja
makedepends = python
- makedepends = qt5-tools
+ makedepends = qt5-base
makedepends = qt5-multimedia
- depends = glew
- depends = glibc
- depends = libgl
- depends = sdl2
- depends = zlib
- depends = snappy
+ makedepends = qt5-tools
+ makedepends = sdl2
+ makedepends = snappy
+ makedepends = zlib
+ options = !lto
source = git+https://github.com/hrydgard/ppsspp.git
source = git+https://github.com/Kingcom/armips.git
source = git+https://github.com/discordapp/discord-rpc.git
- source = ppsspp-ffmpeg::git+https://github.com/hrydgard/ppsspp-ffmpeg.git
- source = ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
+ source = git+https://github.com/hrydgard/ppsspp-ffmpeg.git
+ source = armips-filesystem::git+https://github.com/Kingcom/filesystem.git
+ source = git+https://github.com/KhronosGroup/glslang.git
source = git+https://github.com/hrydgard/ppsspp-lang.git
+ source = ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
source = git+https://github.com/Tencent/rapidjson.git
source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
- source = armips-filesystem::git+https://github.com/Kingcom/filesystem.git
- source = git+https://github.com/facebook/zstd.git
source = git+https://github.com/google/cpu_features.git
- source = ppsspp.desktop
+ source = ppsspp-sdl.desktop
source = ppsspp-qt.desktop
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = 77a88e75f3c090856442b11c8d3f24ed95cc9ca0da1e3f22a40b700b30a3a7b7
- sha256sums = 7456207ba3759ee93709e25b7bfce5b560a8cb432e2d578ef0f98cb6da6c4d15
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = c6bcdfedee866dfdcc82a8c333c31ff73ed0beec65b63acec8bc8186383c0bc9f0912f21bb9715b665e8dc1793b1a85599761f9037856fa54ad8aa3bfdbfd468
+ b2sums = 328e2ba47b78d242b0ec6ba6bfa039c77a36d1ef7246e5c2c2432d8e976e9360baf505eb05f48408ede1a30545cbbb7f875bf5ebd0252cef35523d449b8254a0
pkgname = ppsspp-git
depends = glew
depends = glibc
- depends = libgl
- depends = sdl2
- depends = zlib
- depends = snappy
depends = hicolor-icon-theme
- depends = libzip
- depends = ppsspp-common-git
- provides = ppsspp
- conflicts = ppsspp
-
-pkgname = ppsspp-headless-git
- pkgdesc = A PSP emulator written in C++ (headless)
- depends = glew
- depends = glibc
- depends = libgl
- depends = sdl2
- depends = zlib
- depends = snappy
- depends = ppsspp-common-git
- provides = ppsspp-headless
- conflicts = ppsspp-headless
-
-pkgname = ppsspp-qt-git
- pkgdesc = A PSP emulator written in C++ (with Qt frontend)
- depends = glew
- depends = glibc
depends = libgl
- depends = sdl2
- depends = zlib
- depends = snappy
- depends = hicolor-icon-theme
depends = libzip
+ depends = ppsspp-assets-git
depends = qt5-base
depends = qt5-multimedia
- depends = ppsspp-common-git
- provides = ppsspp-qt
- conflicts = ppsspp-qt
+ depends = sdl2
+ depends = snappy
+ depends = zlib
+ depends = zstd
+ provides = ppsspp
+ conflicts = ppsspp
-pkgname = ppsspp-common-git
- pkgdesc = A PSP emulator written in C++ (common assets)
- depends =
+pkgname = ppsspp-assets-git
+ provides = ppsspp-assets
+ conflicts = ppsspp-assets
diff --git a/PKGBUILD b/PKGBUILD
index 69664aceb7f3..c82aef44f795 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: David Wu <xdavidwuph@gmail.com>
+# Maintainer:
+# Contributor: David Wu <xdavidwuph@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Ben Reedy <thebenj88@gmail.com>
@@ -6,189 +7,152 @@
# Contributor: Thiago Kenji Okada <thiago.mast3r@gmail.com>
# Contributor: uberushaximus <uberushaximus@gmail.com>
-pkgbase=ppsspp-git
pkgname=(
ppsspp-git
- ppsspp-headless-git
- ppsspp-qt-git
- ppsspp-common-git
+ ppsspp-assets-git
)
-pkgver=1.13.2.r1362.b7f79dd8b
+pkgver=1.14.4.r1397.baa066c7b7
pkgrel=1
pkgdesc='A PSP emulator written in C++'
arch=(x86_64)
-url=http://www.ppsspp.org/
+url=https://www.ppsspp.org/
license=(GPL2)
-depends=(
- glew
- glibc
- libgl
- sdl2
- zlib
- snappy
-)
makedepends=(
+ clang
+ lld
cmake
git
+ glew
+ glu
libglvnd
libzip
+ ninja
python
- qt5-tools
+ qt5-base
qt5-multimedia
+ qt5-tools
+ sdl2
+ snappy
+ zlib
)
+options=(!lto)
source=(
git+https://github.com/hrydgard/ppsspp.git
git+https://github.com/Kingcom/armips.git
git+https://github.com/discordapp/discord-rpc.git
- ppsspp-ffmpeg::git+https://github.com/hrydgard/ppsspp-ffmpeg.git
- ppsspp-glslang::git+https://github.com/hrydgard/glslang.git
+ git+https://github.com/hrydgard/ppsspp-ffmpeg.git
+ armips-filesystem::git+https://github.com/Kingcom/filesystem.git
+ git+https://github.com/KhronosGroup/glslang.git
git+https://github.com/hrydgard/ppsspp-lang.git
+ ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
git+https://github.com/Tencent/rapidjson.git
git+https://github.com/KhronosGroup/SPIRV-Cross.git
- armips-filesystem::git+https://github.com/Kingcom/filesystem.git
- git+https://github.com/facebook/zstd.git
git+https://github.com/google/cpu_features.git
- ppsspp.desktop
+ ppsspp-sdl.desktop
ppsspp-qt.desktop
)
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '77a88e75f3c090856442b11c8d3f24ed95cc9ca0da1e3f22a40b700b30a3a7b7'
- '7456207ba3759ee93709e25b7bfce5b560a8cb432e2d578ef0f98cb6da6c4d15')
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'c6bcdfedee866dfdcc82a8c333c31ff73ed0beec65b63acec8bc8186383c0bc9f0912f21bb9715b665e8dc1793b1a85599761f9037856fa54ad8aa3bfdbfd468'
+ '328e2ba47b78d242b0ec6ba6bfa039c77a36d1ef7246e5c2c2432d8e976e9360baf505eb05f48408ede1a30545cbbb7f875bf5ebd0252cef35523d449b8254a0')
pkgver() {
cd ppsspp
-
- echo "$(git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./')"
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
}
prepare() {
cd ppsspp
-
- for submodule in assets/lang ext/glslang ffmpeg; do
+ for submodule in assets/lang ext/miniupnp ffmpeg; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
git -c protocol.file.allow=always submodule update ${submodule}
done
- for submodule in ext/{armips,discord-rpc,rapidjson,SPIRV-Cross,zstd,cpu_features}; do
+ for submodule in ext/{armips,discord-rpc,rapidjson,SPIRV-Cross,cpu_features,glslang}; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../${submodule#*/}
git -c protocol.file.allow=always submodule update ${submodule}
done
-
- git submodule init ext/miniupnp
- git -c protocol.file.allow=always submodule update ext/miniupnp
-
- pushd ext/armips
-
+ cd ext/armips
for submodule in ext/filesystem; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../../../armips-${submodule#*/}
git -c protocol.file.allow=always submodule update ${submodule}
done
-
- popd
-
- for ui in sdl qt; do
- if [[ -d build-$ui ]]; then
- rm -rf build-$ui
- fi
- mkdir build-$ui
- done
}
build() {
- cd ppsspp/build-sdl
-
- cmake .. \
+ export CC=clang
+ export CXX=clang++
+ # Rebuild ffmpeg locally
+ pushd ppsspp/ffmpeg
+ ./linux_x86-64.sh
+ popd
+ cmake -S ppsspp -B build-sdl -G Ninja \
+ -Wno-dev \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
-DHEADLESS=ON \
+ -DOpenGL_GL_PREFERENCE=GLVND \
-DUSE_SYSTEM_LIBZIP=ON \
-DUSE_SYSTEM_SNAPPY=ON \
- -DOpenGL_GL_PREFERENCE=GLVND
- make
-
- cd ../build-qt
-
- cmake .. \
+ -DUSE_SYSTEM_ZSTD=ON \
+ -DUSING_QT_UI=OFF
+ cmake --build build-sdl -v
+ cmake -S ppsspp -B build-qt -G Ninja \
+ -Wno-dev \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON \
+ -DHEADLESS=OFF \
+ -DOpenGL_GL_PREFERENCE=GLVND \
-DUSE_SYSTEM_LIBZIP=ON \
- -DUSING_QT_UI=ON \
-DUSE_SYSTEM_SNAPPY=ON \
- -DOpenGL_GL_PREFERENCE=GLVND
- make
+ -DUSE_SYSTEM_ZSTD=ON \
+ -DUSING_QT_UI=ON
+ cmake --build build-qt -v
}
package_ppsspp-git() {
- depends+=(
- hicolor-icon-theme
- libzip
- ppsspp-common-git
- )
- provides=(ppsspp)
- conflicts=(ppsspp)
-
- cd ppsspp/build-sdl
-
- install -dm 755 "${pkgdir}"/usr/{bin,share/applications}
- install -m 755 PPSSPPSDL "${pkgdir}"/usr/bin/
- install -m 644 ../../ppsspp.desktop "${pkgdir}"/usr/share/applications/
-}
-
-package_ppsspp-headless-git() {
- depends+=(
- ppsspp-common-git
- )
- provides=(ppsspp-headless)
- conflicts=(ppsspp-headless)
- pkgdesc='A PSP emulator written in C++ (headless)'
-
- cd ppsspp/build-sdl
-
- install -dm 755 "${pkgdir}"/usr/bin
- install -m 755 PPSSPPHeadless "${pkgdir}"/usr/bin/
-}
-
-package_ppsspp-qt-git() {
- depends+=(
+ depends=(
+ glew
+ glibc
hicolor-icon-theme
+ libgl
libzip
+ ppsspp-assets-git
qt5-base
qt5-multimedia
- ppsspp-common-git
+ sdl2
+ snappy
+ zlib
+ zstd
)
- provides=(ppsspp-qt)
- conflicts=(ppsspp-qt)
- pkgdesc='A PSP emulator written in C++ (with Qt frontend)'
-
- cd ppsspp/build-qt
-
- install -dm 755 "${pkgdir}"/usr/{bin,share/applications}
- install -m 755 PPSSPPQt "${pkgdir}"/usr/bin/
- install -m 644 ../../ppsspp-qt.desktop "${pkgdir}"/usr/share/applications/
+ provides=(ppsspp)
+ conflicts=(ppsspp)
+ install -Dm 755 build-sdl/PPSSPPSDL -t "${pkgdir}"/usr/bin/
+ install -Dm 755 build-sdl/PPSSPPHeadless -t "${pkgdir}"/usr/bin/
+ install -Dm 755 build-qt/PPSSPPQt -t "${pkgdir}"/usr/bin/
+ install -dm 755 "${pkgdir}"/usr/share/icons
+ cp -dr --no-preserve=ownership ppsspp/icons/hicolor "${pkgdir}"/usr/share/icons/
+ install -Dm 644 ppsspp/icons/icon-512.svg "${pkgdir}"/usr/share/pixmaps/ppsspp.svg
+ install -Dm 644 ppsspp-sdl.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm 644 ppsspp-qt.desktop -t "${pkgdir}"/usr/share/applications/
}
-package_ppsspp-common-git() {
- depends=()
- pkgdesc='A PSP emulator written in C++ (common assets)'
-
- cd ppsspp/build-qt
-
- install -dm 755 "${pkgdir}"/usr/share/{applications,icons,pixmaps,ppsspp}
- cp -dr --no-preserve=ownership assets "${pkgdir}"/usr/share/ppsspp/
- cp -dr --no-preserve=ownership ../icons/hicolor "${pkgdir}"/usr/share/icons/
- install -m 644 ../icons/icon-512.svg "${pkgdir}"/usr/share/pixmaps/ppsspp.svg
+package_ppsspp-assets-git() {
+ provides=(ppsspp-assets)
+ conflicts=(ppsspp-assets)
+ install -dm 755 "${pkgdir}"/usr/share/ppsspp
+ cp -dr --no-preserve=ownership build-sdl/assets "${pkgdir}"/usr/share/ppsspp/
}
# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
new file mode 100644
index 000000000000..da5767b555e5
--- /dev/null
+++ b/PKGBUILD.testing
@@ -0,0 +1,179 @@
+# Maintainer:
+# Contributor: David Wu <xdavidwuph@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ben Reedy <thebenj88@gmail.com>
+# Contributor: Clement Guerin <geecko.dev@free.fr>
+# Contributor: Thiago Kenji Okada <thiago.mast3r@gmail.com>
+# Contributor: uberushaximus <uberushaximus@gmail.com>
+
+pkgname=(
+ ppsspp-git
+ ppsspp-assets-git
+)
+pkgver=1.14.4.r1397.baa066c7b7
+pkgrel=1
+_ffver=3.0.12
+pkgdesc='A PSP emulator written in C++'
+arch=(x86_64)
+url=https://www.ppsspp.org/
+license=(GPL2)
+makedepends=(
+ clang
+ lld
+ cmake
+ git
+ glew
+ glu
+ libglvnd
+ libzip
+ ninja
+ python
+ qt5-base
+ qt5-multimedia
+ qt5-tools
+ sdl2
+ snappy
+ zlib
+)
+options=(!lto)
+source=(
+ git+https://github.com/hrydgard/ppsspp.git
+ git+https://github.com/Kingcom/armips.git
+ git+https://github.com/discordapp/discord-rpc.git
+ https://ffmpeg.org/releases/ffmpeg-$_ffver.tar.xz
+ ppsspp-ffmpeg_x86_64.sh::https://raw.githubusercontent.com/hrydgard/ppsspp-ffmpeg/master/linux_x86-64.sh
+ armips-filesystem::git+https://github.com/Kingcom/filesystem.git
+ git+https://github.com/KhronosGroup/glslang.git
+ git+https://github.com/hrydgard/ppsspp-lang.git
+ ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
+ git+https://github.com/Tencent/rapidjson.git
+ git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ git+https://github.com/google/cpu_features.git
+ ppsspp-sdl.desktop
+ ppsspp-qt.desktop
+)
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e978c76cdab638d4bf2718e0ec58fb0d4c7c4017d3100de76460fc8b148cb899066dbe92680aad19f7bd60c7c8924d966fcee22a53133be695ac8352a6ed01cc'
+ 'd5140fb7d56e3b7873a3174e3b9c96a5188309daa77b534d2e7e6355b6d74db4f672d8dc8daa968f272e824c9832fdac88e74794c93a4ac6b5aec271ddeada13'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'c6bcdfedee866dfdcc82a8c333c31ff73ed0beec65b63acec8bc8186383c0bc9f0912f21bb9715b665e8dc1793b1a85599761f9037856fa54ad8aa3bfdbfd468'
+ '328e2ba47b78d242b0ec6ba6bfa039c77a36d1ef7246e5c2c2432d8e976e9360baf505eb05f48408ede1a30545cbbb7f875bf5ebd0252cef35523d449b8254a0')
+
+pkgver() {
+ cd ppsspp
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
+}
+
+prepare() {
+ cd ppsspp
+ if [[ -d ffmpeg ]]; then
+ rm -rf ffmpeg
+ fi
+ cp -r "$srcdir"/ffmpeg-$_ffver ffmpeg
+ cp "$srcdir"/ppsspp-ffmpeg_x86_64.sh ffmpeg/
+ chmod u+x ffmpeg/ppsspp-ffmpeg_x86_64.sh
+ for submodule in assets/lang ext/miniupnp; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
+ git -c protocol.file.allow=always submodule update ${submodule}
+ done
+ for submodule in ext/{armips,discord-rpc,rapidjson,SPIRV-Cross,cpu_features,glslang}; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../${submodule#*/}
+ git -c protocol.file.allow=always submodule update ${submodule}
+ done
+ cd ext/armips
+ for submodule in ext/filesystem; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../../../armips-${submodule#*/}
+ git -c protocol.file.allow=always submodule update ${submodule}
+ done
+}
+
+build() {
+ export CC=clang
+ export CXX=clang++
+ # Rebuild ffmpeg locally
+ pushd ppsspp/ffmpeg
+ ./ppsspp-ffmpeg_x86_64.sh
+ popd
+ cmake -S ppsspp -B build-sdl -G Ninja \
+ -Wno-dev \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_C_COMPILER=clang \
+ -DCMAKE_CXX_COMPILER=clang++ \
+ -DCMAKE_EXE_LINKER_FLAGS_INIT="-fuse-ld=lld" \
+ -DCMAKE_MODULE_LINKER_FLAGS_INIT="-fuse-ld=lld" \
+ -DCMAKE_SHARED_LINKER_FLAGS_INIT="-fuse-ld=lld" \
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DHEADLESS=ON \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ -DUSE_SYSTEM_LIBZIP=ON \
+ -DUSE_SYSTEM_SNAPPY=ON \
+ -DUSE_SYSTEM_ZSTD=ON \
+ -DUSING_QT_UI=OFF
+ cmake --build build-sdl -v
+ cmake -S ppsspp -B build-qt -G Ninja \
+ -Wno-dev \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_C_COMPILER=clang \
+ -DCMAKE_CXX_COMPILER=clang++ \
+ -DCMAKE_EXE_LINKER_FLAGS_INIT="-fuse-ld=lld" \
+ -DCMAKE_MODULE_LINKER_FLAGS_INIT="-fuse-ld=lld" \
+ -DCMAKE_SHARED_LINKER_FLAGS_INIT="-fuse-ld=lld" \
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DHEADLESS=OFF \
+ -DOpenGL_GL_PREFERENCE=GLVND \
+ -DUSE_SYSTEM_LIBZIP=ON \
+ -DUSE_SYSTEM_SNAPPY=ON \
+ -DUSE_SYSTEM_ZSTD=ON \
+ -DUSING_QT_UI=ON
+ cmake --build build-qt -v
+}
+
+package_ppsspp-git() {
+ depends=(
+ glew
+ glibc
+ hicolor-icon-theme
+ libgl
+ libzip
+ ppsspp-assets-git
+ qt5-base
+ qt5-multimedia
+ sdl2
+ snappy
+ zlib
+ zstd
+ )
+ provides=(ppsspp)
+ conflicts=(ppsspp)
+ install -Dm 755 build-sdl/PPSSPPSDL -t "${pkgdir}"/usr/bin/
+ install -Dm 755 build-sdl/PPSSPPHeadless -t "${pkgdir}"/usr/bin/
+ install -Dm 755 build-qt/PPSSPPQt -t "${pkgdir}"/usr/bin/
+ install -dm 755 "${pkgdir}"/usr/share/icons
+ cp -dr --no-preserve=ownership ppsspp/icons/hicolor "${pkgdir}"/usr/share/icons/
+ install -Dm 644 ppsspp/icons/icon-512.svg "${pkgdir}"/usr/share/pixmaps/ppsspp.svg
+ install -Dm 644 ppsspp-sdl.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm 644 ppsspp-qt.desktop -t "${pkgdir}"/usr/share/applications/
+}
+
+package_ppsspp-assets-git() {
+ provides=(ppsspp-assets)
+ conflicts=(ppsspp-assets)
+ install -dm 755 "${pkgdir}"/usr/share/ppsspp
+ cp -dr --no-preserve=ownership build-sdl/assets "${pkgdir}"/usr/share/ppsspp/
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/ppsspp-qt.desktop b/ppsspp-qt.desktop
index 0a274c1be7e7..772dd5dcb921 100644
--- a/ppsspp-qt.desktop
+++ b/ppsspp-qt.desktop
@@ -3,7 +3,7 @@ Version=1.0
Type=Application
Name=PPSSPP (Qt)
GenericName=PSP Emulator
-Comment=PlayStation Portable Simulator Suitable for Playing Portably (PPSSPP)
+Comment=PlayStation Portable Simulator Suitable for Playing Portably
Exec=PPSSPPQt %f
Icon=ppsspp
Categories=Game
diff --git a/ppsspp.desktop b/ppsspp-sdl.desktop
index cf3a3da1a456..bf94acc80894 100644
--- a/ppsspp.desktop
+++ b/ppsspp-sdl.desktop
@@ -1,9 +1,9 @@
[Desktop Entry]
Version=1.0
Type=Application
-Name=PPSSPP
+Name=PPSSPP (SDL)
GenericName=PSP Emulator
-Comment=PlayStation Portable Simulator Suitable for Playing Portably (PPSSPP)
+Comment=PlayStation Portable Simulator Suitable for Playing Portably
Exec=PPSSPPSDL %f
Icon=ppsspp
Categories=Game