summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott R. Santos2015-09-19 15:23:37 -0400
committerScott R. Santos2015-09-19 15:23:37 -0400
commit975288cbbfdbe558bb48a4a5a3b658c4fa8ba230 (patch)
tree7f27799b0e03e3a0ae1284a92b1aa1d4bee4eb6b
downloadaur-975288cbbfdbe558bb48a4a5a3b658c4fa8ba230.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee695ab133e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 4.2.0
+# Sat Feb 14 10:30:22 UTC 2015
+pkgbase = ppub
+ pkgdesc = Simple epub reader written using python, gtk3 and webkit
+ pkgver = 1.1
+ pkgrel = 3
+ url = https://github.com/sakisds/pPub
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = make
+ depends = python2
+ depends = gtk3
+ depends = gobject-introspection
+ depends = libwebkit3
+ depends = python2-gobject
+ source = git+https://github.com/sakisds/pPub.git#commit=3d1686070f34c125e266b22a346f320a47691103
+ md5sums = SKIP
+
+pkgname = ppub
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d301e1a61f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Scott R. Santos <halocaridina at gmail.com>
+# Contributor: Jonathan Steel <jsteel at archlinux.org>
+# Contributor: Yamakaky <yamakaky@yamaworld.fr>
+# Contributor: Thanasis Georgiou <sakisds@gmx.com>
+# Contributor: PyroDevil <p dot devil at gmail dot com>
+
+pkgname=ppub
+pkgver=1.1
+pkgrel=3
+pkgdesc="Simple epub reader written using python, gtk3 and webkit"
+arch=('any')
+license=('GPL2')
+url="https://github.com/sakisds/pPub"
+depends=('python2' 'gtk3' 'gobject-introspection' 'libwebkit3'
+ 'python2-gobject')
+makedepends=('git' 'make')
+source=("git+https://github.com/sakisds/pPub.git#commit=3d1686070f34c125e266b22a346f320a47691103")
+md5sums=('SKIP')
+
+build() {
+ cd pPub
+
+ make ppub
+}
+
+package() {
+ cd pPub
+
+ make PREFIX="$pkgdir/usr" install
+}