summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Tournoij2015-08-20 12:40:52 +0200
committerMartin Tournoij2015-08-20 12:40:52 +0200
commitb7d29f7070ed5a0778d3102f8b3239dd120d6ff7 (patch)
tree9fa53d1b13641091249f397853389329b852dc3e
downloadaur-b7d29f7070ed5a0778d3102f8b3239dd120d6ff7.tar.gz
Bring back pqiv
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2fb1d863e3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pqiv
+ pkgdesc = Modern rewrite of Quick Image Viewer
+ pkgver = 2.3.5
+ pkgrel = 1
+ url = https://github.com/phillipberndt/pqiv/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gtk2
+ optdepends = libspectre: PS/EPS support
+ optdepends = poppler: PDF support
+ optdepends = imagemagick: additional image formats like psd
+ source = pqiv-2.3.5.tar.gz::https://github.com/phillipberndt/pqiv/archive/2.3.5.tar.gz
+ sha256sums = e3913ce83e708b16071925ba09888734893d9c66bc2130f5f575398f05e02460
+
+pkgname = pqiv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72b7018fa110
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Martin Tournoij <martin@arp242.net>
+
+pkgname=pqiv
+pkgver=2.3.5
+pkgrel=1
+pkgdesc="Modern rewrite of Quick Image Viewer"
+arch=('i686' 'x86_64')
+url="https://github.com/phillipberndt/pqiv/"
+license=('GPL3')
+depends=('gtk2') # Also works with GTK3...
+optdepends=(
+'libspectre: PS/EPS support'
+'poppler: PDF support'
+'imagemagick: additional image formats like psd'
+)
+install=
+source=($pkgname-$pkgver.tar.gz::https://github.com/phillipberndt/pqiv/archive/$pkgver.tar.gz)
+sha256sums=('e3913ce83e708b16071925ba09888734893d9c66bc2130f5f575398f05e02460')
+
+build() {
+ cd $pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}