summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsfx2016-04-25 18:41:17 +0200
committersfx2016-04-25 18:41:17 +0200
commita1921994f70cb8bbd4148ff0876a3105539e9fc5 (patch)
tree75ebbbdf3a6427f758f9ad7dd575cfd29890891a
parent7e3137dad4bd6c6babc15fb69e89d7f16724a134 (diff)
downloadaur-a1921994f70cb8bbd4148ff0876a3105539e9fc5.tar.gz
Update: comic books support included
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD17
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 988b1eb1452b..0600572914c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pqiv-git
pkgdesc = Modern rewrite of Quick Image Viewer - development version
- pkgver = 2.3.r37.gac5de03
+ pkgver = 2.3.r171.gdd7511b
pkgrel = 1
- url = https://github.com/phillipberndt/pqiv/
+ url = https://github.com/phillipberndt/pqiv
arch = i686
arch = x86_64
license = GPL3
@@ -11,6 +11,7 @@ pkgbase = pqiv-git
optdepends = libspectre: PS/EPS support
optdepends = poppler: PDF support
optdepends = imagemagick: additional image formats like psd
+ optdepends = libarchive: comic books support
optdepends = ffmpeg: basic video support e.g. WEBM
provides = pqiv
conflicts = pqiv
diff --git a/.gitignore b/.gitignore
index 62d30f9218cb..8503a5bb2e01 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,5 @@
-src/
-pkg/
+src
+pkg
+pqiv
+pqiv-git-*
+.update
diff --git a/PKGBUILD b/PKGBUILD
index 72c77a506e0c..0e8f0b59fa13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ I_WANT_WEBM_SUPPORT=yes
_name=pqiv
pkgname=$_name-git
-pkgver=2.3.r37.gac5de03
+pkgver=2.3.r171.gdd7511b
pkgrel=1
pkgdesc="Modern rewrite of Quick Image Viewer - development version"
arch=('i686' 'x86_64')
-url="https://github.com/phillipberndt/pqiv/"
+url="https://github.com/phillipberndt/pqiv"
license=('GPL3')
provides=("$_name")
conflicts=("$_name")
@@ -19,16 +19,17 @@ depends=('gtk3')
#depends=('gtk2')
makedepends=('git')
optdepends=(
- 'libspectre: PS/EPS support'
- 'poppler: PDF support'
- 'imagemagick: additional image formats like psd'
+ 'libspectre: PS/EPS support'
+ 'poppler: PDF support'
+ 'imagemagick: additional image formats like psd'
+ 'libarchive: comic books support'
)
if [ $I_WANT_WEBM_SUPPORT = yes ]; then
optdepends+=('ffmpeg: basic video support e.g. WEBM')
fi
-source=(git+https://github.com/phillipberndt/pqiv)
+source=(git+$url)
sha256sums=(SKIP)
pkgver() {
@@ -40,10 +41,10 @@ build() {
cd $_name
if [ $I_WANT_WEBM_SUPPORT = yes ]; then
- ./configure --with-libav
+ ./configure --backends-build=shared --with-libav
else
- ./configure
+ ./configure --backends-build=shared
fi