summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsfx2015-08-21 14:32:55 +0200
committersfx2015-08-21 14:32:55 +0200
commitea47d9841657e9cef1d66c896fc2c02ab931eb7f (patch)
tree43fe116fce9595e5eec78fe532aeccc5a3dfeedf
downloadaur-ea47d9841657e9cef1d66c896fc2c02ab931eb7f.tar.gz
Initial import. WEBM as optdeps not enabled.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD56
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f656cbf125c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pqiv-git
+ pkgdesc = Modern rewrite of Quick Image Viewer - development version
+ pkgver = 2.3.r37.gac5de03
+ pkgrel = 1
+ url = https://github.com/phillipberndt/pqiv/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = gtk3
+ optdepends = libspectre: PS/EPS support
+ optdepends = poppler: PDF support
+ optdepends = imagemagick: additional image formats like psd
+ optdepends = ffmpeg: basic video support e.g. WEBM
+ provides = pqiv
+ conflicts = pqiv
+ source = git+https://github.com/phillipberndt/pqiv#branch=libav
+ sha256sums = SKIP
+
+pkgname = pqiv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1dcb8e96b55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: flu
+
+I_WANT_WEBM_SUPPORT=yes
+
+
+#---------------
+
+_name=pqiv
+pkgname=$_name-git
+pkgver=2.3.r37.gac5de03
+pkgrel=1
+pkgdesc="Modern rewrite of Quick Image Viewer - development version"
+arch=('i686' 'x86_64')
+url="https://github.com/phillipberndt/pqiv/"
+license=('GPL3')
+provides=("$_name")
+conflicts=("$_name")
+depends=('gtk3')
+#depends=('gtk2')
+makedepends=('git')
+optdepends=(
+ 'libspectre: PS/EPS support'
+ 'poppler: PDF support'
+ 'imagemagick: additional image formats like psd'
+)
+
+if [ $I_WANT_WEBM_SUPPORT = yes ]; then
+ optdepends+=('ffmpeg: basic video support e.g. WEBM')
+fi
+
+source=(git+https://github.com/phillipberndt/pqiv#branch=libav)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir"/"$_name"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_name
+
+ if [ $I_WANT_WEBM_SUPPORT = yes ]; then
+ ./configure --with-libav
+
+ else
+ ./configure
+
+ fi
+
+ make
+}
+
+package() {
+ cd $_name
+ make DESTDIR=$pkgdir install
+}