summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Schneider2012-08-20 11:17:43 +0200
committerSven Schneider2012-08-20 11:17:43 +0200
commit88b30b21b3162a4bd9b3865c82722d7b38cc808d (patch)
tree32a6fa9f44f5bfbc1fbcd41e35397205369fd636
downloadaur-88b30b21b3162a4bd9b3865c82722d7b38cc808d.tar.gz
pqp: added
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE32
-rw-r--r--PKGBUILD37
-rw-r--r--fpic.patch11
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0fd0edebb02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pqp
+ pkgdesc = A library for performing proximity queries on a pair of geometric models composed of triangles
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://gamma.cs.unc.edu/SSV/
+ arch = i686
+ arch = x86_64
+ license = Custom
+ source = http://gamma.cs.unc.edu/software/downloads/SSV/pqp-1.3.tar.gz
+ source = LICENSE
+ source = fpic.patch
+ md5sums = f710e24a62db763d61d08667439d46fd
+ md5sums = a84efad9de33fd28444fa14f9bd7d273
+ md5sums = 4bc614687ef5b95df3b9be31ca46c662
+
+pkgname = pqp
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8a5575c0b4d8
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,32 @@
+Copyright 1999 University of North Carolina at Chapel Hill.
+All rights reserved.
+
+Permission to use, copy, modify, and distribute this software and its
+documentation for educational, research, and non-profit purposes, without fee,
+and without a written agreement is hereby granted, provided that the above
+copyright notice and the following three paragraphs appear in all copies.
+
+IN NO EVENT SHALL THE UNIVERSITY OF NORTH CAROLINA AT CHAPEL HILL BE LIABLE TO
+ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES,
+INCLUDING LOST PROFITS, ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS
+DOCUMENTATION, EVEN IF THE UNIVERSITY OF NORTH CAROLINA AT CHAPEL HILL HAS
+BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
+
+THE UNIVERSITY OF NORTH CAROLINA AT CHAPEL HILL SPECIFICALLY DISCLAIMS ANY
+WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE PROVIDED
+HEREUNDER IS ON AN "AS IS" BASIS, AND THE UNIVERSITY OF NORTH CAROLINA AT
+CHAPEL HILL HAS NO OBLIGATIONS TO PROVIDE MAINTENANCE, SUPPORT, UPDATES,
+ENHANCEMENTS, OR MODIFICATIONS.
+
+The authors may be contacted via:
+
+US Mail: Eric Larsen, Stefan Gottschalk
+ Department of Computer Science
+ Sitterson Hall, CB #3175
+ University of North Carolina
+ Chapel Hill, NC 27599-3175
+
+Phone: (919) 962-1749
+
+Email: geom@cs.unc.edu
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a4bca07160d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=pqp
+pkgver=1.3
+pkgrel=1
+pkgdesc="A library for performing proximity queries on a pair of geometric models composed of triangles"
+arch=('i686' 'x86_64')
+url="http://gamma.cs.unc.edu/SSV/"
+license=('Custom')
+depends=()
+source=(http://gamma.cs.unc.edu/software/downloads/SSV/${pkgname}-${pkgver}.tar.gz
+ LICENSE
+ fpic.patch)
+md5sums=('f710e24a62db763d61d08667439d46fd'
+ 'a84efad9de33fd28444fa14f9bd7d273'
+ '4bc614687ef5b95df3b9be31ca46c662')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/PQP_v1.3"
+
+ patch -p2 < ${srcdir}/fpic.patch
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/PQP_v1.3"
+
+ install -dm755 "${pkgdir}/usr/include/"
+ install -dm755 "${pkgdir}/usr/lib/"
+
+ install include/* "${pkgdir}/usr/include/"
+ install lib/libPQP.a "${pkgdir}/usr/lib/"
+
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/fpic.patch b/fpic.patch
new file mode 100644
index 000000000000..def20f5f1940
--- /dev/null
+++ b/fpic.patch
@@ -0,0 +1,11 @@
+diff -Nur pqp-1.3.orig/PQP_v1.3/Makefile pqp-1.3/PQP_v1.3/Makefile
+--- pqp-1.3.orig/PQP_v1.3/Makefile 2002-04-21 18:55:38.000000000 +0200
++++ pqp-1.3/PQP_v1.3/Makefile 2011-11-22 16:43:41.000000000 +0100
+@@ -1,6 +1,6 @@
+ CC = g++
+
+-CFLAGS = -O2 -I.
++CFLAGS = -O2 -fPIC -I.
+
+ .SUFFIXES: .C .cpp
+