summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Brinister2020-09-06 00:18:43 -0400
committerAlex Brinister2020-09-06 00:19:46 -0400
commit040fd39c49272247f0e7f977f3d715f4ed607ad0 (patch)
treede455bf26e796b321f39a64beb1625cb841c468c
parent221d180ffaeb51c916668b778eb4ffc1e6bf3734 (diff)
downloadaur-040fd39c49272247f0e7f977f3d715f4ed607ad0.tar.gz
Applied patch to fix mkstemp and link issues
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4e3a29e2d9c..f56ef514cd18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Kingan <kingan201 at gmail dot com>
+# Maintainer: Alex Brinister <alex_brinister at yahoo dot com>
+# Contributor: Kingan <kingan201 at gmail dot com>
# Contributor: Frederic Bezies <fredbezies at gmail dot com>
# Contributor: Valsu [arch(at)hylia.de]
pkgname='prboom-plus'
pkgver='2.5.1.4'
-pkgrel='3'
+pkgrel='4'
pkgdesc='An advanced, Vanilla-compatible Doom engine based on PrBoom'
url='http://prboom-plus.sourceforge.net/'
arch=('x86_64' 'i686')
@@ -14,10 +15,14 @@ conflicts=('prboom-plus-svn')
source=("http://download.sourceforge.net/prboom-plus/prboom-plus-$pkgver.tar.gz")
sha1sums=('73b3b46c36aa693059f2762dcd807bfd0490f130')
+prepare() {
+ sed -i -E 's/mktemp/mkstemp/g' $(find "prboom-plus-$pkgver" -type f -name r_demo.c)
+}
+
build() {
cd "prboom-plus-$pkgver"
- ./configure --prefix=/usr --without-dumb
+ LDFLAGS="-z muldefs" ./configure --prefix=/usr --without-dumb
make
}