summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-12 18:06:10 -0500
committerCarlos Aznarán2024-04-12 18:06:10 -0500
commitac44f7c64eab82936f5235c6d8362fbb02ce5ea8 (patch)
treec349e341811aee762944bfb085dbcebb5ed1c1b0
downloadaur-ac44f7c64eab82936f5235c6d8362fbb02ce5ea8.tar.gz
Bump version to 0.1.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD25
4 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8401dc3008a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = precice-config-visualizer-gui
+ pkgdesc = A GUI tool for visualizing a preCICE configuration file as a dot file
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/precice/config-visualizer-gui
+ arch = any
+ license = GPL-3.0-or-later
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = precice-config-visualizer
+ depends = xdot
+ source = config-visualizer-gui-0.1.0.tar.gz::https://github.com/precice/config-visualizer-gui/archive/v0.1.0.tar.gz
+ sha512sums = 932f54755e8b3cecc3c9dafd867d6eb8088c1fce9c2478ff12669d9b2da7c2f91ee137751fbf18fe1528ee382e7171cedb80a9809f3587cbfafee4f7095af17c
+
+pkgname = precice-config-visualizer-gui
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..b35bc57ed2b6
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[precice-config-visualizer-gui]
+source = "github"
+github = "precice/config-visualizer-gui"
+use_max_tag = "true"
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e40c0cc96f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=precice-config-visualizer-gui
+pkgname=${_base}
+pkgdesc="A GUI tool for visualizing a preCICE configuration file as a dot file"
+pkgver=0.1.0
+pkgrel=1
+arch=(any)
+url="https://github.com/precice/${_base/precice-/}"
+license=(GPL-3.0-or-later)
+depends=(precice-config-visualizer xdot)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(${_base/precice-/}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('932f54755e8b3cecc3c9dafd867d6eb8088c1fce9c2478ff12669d9b2da7c2f91ee137751fbf18fe1528ee382e7171cedb80a9809f3587cbfafee4f7095af17c')
+
+build() {
+ cd ${_base/precice-/}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+package() {
+ cd ${_base/precice-/}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}