summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Stoetzer2018-05-27 15:33:15 -0400
committerPaul Stoetzer2018-05-27 15:33:15 -0400
commit230919e3297f53382a0bb0529ce9cdd9a00a5367 (patch)
tree29800cf170aaf6418895906a0b11e874221a7161
downloadaur-230919e3297f53382a0bb0529ce9cdd9a00a5367.tar.gz
First upload of PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08a40c9f4921
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = predict
+ pkgdesc = Satellite tracking, orbital prediction, open-source software
+ pkgver = 2.2.5
+ pkgrel = 1
+ url = http://www.qsl.net/kd2bd/predict.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ provides = predict
+ options = !emptydirs
+ source = http://www.qsl.net/kd2bd/predict-2.2.5.tar.bz2
+ md5sums = SKIP
+
+pkgname = predict
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94273bf0d3b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Paul Stoetzer <n8hm at arrl dot net>
+pkgname=predict
+pkgver=2.2.5
+pkgrel=1
+pkgdesc='Satellite tracking, orbital prediction, open-source software'
+arch=('i686' 'x86_64')
+url="http://www.qsl.net/kd2bd/predict.html"
+license=('GPL')
+depends=('ncurses')
+makedepends=()
+provides=('predict')
+conflicts=()
+options=('!emptydirs')
+source=("http://www.qsl.net/kd2bd/predict-2.2.5.tar.bz2")
+md5sums=('SKIP')
+
+build() {
+ cd "predict-2.2.5"
+
+}
+
+package() {
+ cd "predict-2.2.5"
+ ./configure
+ mkdir -p ${pkgdir}/opt/predict/
+ cp -r * ${pkgdir}/opt/predict/
+ mkdir -p ${pkgdir}/usr/bin/
+ ln -s ${pkgdir}/opt/predict/predict ${pkgdir}/usr/bin/predict
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}