summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2024-03-17 20:58:51 +0100
committerAlphaJack2024-03-17 20:58:51 +0100
commit122412128345dc47e4676d65c73c60712eb81fbd (patch)
tree6ffd423ba33aff380312be8a1810bc755f025b8b
downloadaur-122412128345dc47e4676d65c73c60712eb81fbd.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e93f697ae5b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = pretzel-web
+ pkgdesc = Open-source, browser-local data exploration using DuckDB-Wasm and PRQL
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://pretzelai.github.io/
+ arch = any
+ license = Apache-2.0
+ makedepends = npm
+ source = pretzel-web.tar.gz::https://github.com/pretzelai/pretzelai/archive/refs/heads/main.tar.gz
+ b2sums = SKIP
+
+pkgname = pretzel-web
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd1ddaa43b11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="pretzel-web"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Open-source, browser-local data exploration using DuckDB-Wasm and PRQL"
+url="https://pretzelai.github.io/"
+license=("Apache-2.0")
+arch=("any")
+makedepends=("npm")
+source=("$pkgname.tar.gz::https://github.com/pretzelai/pretzelai/archive/refs/heads/main.tar.gz")
+b2sums=("SKIP")
+
+build(){
+ cd "pretzelai-main"
+ npm install
+ npm run build
+}
+
+package(){
+ cd "pretzelai-main"
+ install -d "$pkgdir/usr/share/webapps"
+ mv "build" "$pkgdir/usr/share/webapps/pretzel"
+}