summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJack3G2023-11-26 17:10:49 +1100
committerJack3G2023-11-26 17:10:49 +1100
commit604dce1eb6a7194ecb3c658285b5886545d0c7a2 (patch)
tree73bd5af8034aab0cc09976a77bc5314f240f3f8a
downloadaur-604dce1eb6a7194ecb3c658285b5886545d0c7a2.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.editorconfig6
-rw-r--r--PKGBUILD42
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79eaaf77ecc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = prevodb-databases-git
+ pkgdesc = Dictionary databases for prevodb
+ pkgver = 89173
+ pkgrel = 1
+ url = https://revuloj.github.io/
+ arch = any
+ license = GPL-2.0-only
+ makedepends = git
+ depends = prevodb
+ provides = prevodb-databases
+ conflicts = prevodb-databases
+ source = git+https://github.com/revuloj/revo-fonto.git
+ source = git+https://github.com/revuloj/voko-grundo.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = prevodb-databases-git
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..4f77d623ca1e
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,6 @@
+[PKGBUILD]
+end_of_line = lf
+insert_final_newline = true
+charset = utf-8
+indent_style = space
+indent_size = 3
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6e01f02e5c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jack Baines <jackbaines6 at google mail>
+pkgname=prevodb-databases-git
+pkgver=89173
+pkgrel=1
+pkgdesc="Dictionary databases for prevodb"
+arch=('any')
+url="https://revuloj.github.io/"
+license=('GPL-2.0-only') # Both sources are GPL2
+
+depends=('prevodb')
+makedepends=('git')
+
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+# NOTE: A full depth clone of revo-fonto is 446 MB as of 2023-11-26. The built
+# package is much smaller (47 MB).
+source=('git+https://github.com/revuloj/revo-fonto.git'
+ 'git+https://github.com/revuloj/voko-grundo.git')
+md5sums=('SKIP'
+ 'SKIP')
+
+# The package is made from two different sources, so derive a pkgver by adding
+# each of their revisions. Either can cause an update.
+pkgver() {
+ cd "$srcdir/revo-fonto"
+ local revo_fonto_revision=$(git rev-list --count HEAD)
+
+ cd "$srcdir/voko-grundo"
+ local voko_grundo_revision=$(git rev-list --count HEAD)
+
+ expr $revo_fonto_revision + $voko_grundo_revision
+}
+
+build() {
+ cd "$srcdir"
+ prevodb -s -i revo-fonto -i voko-grundo -o output.db
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm 644 output.db "$pkgdir/usr/share/prevo/prevo.db"
+}