summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxpt2016-10-26 14:37:56 -0300
committerxpt2016-10-26 14:37:56 -0300
commite7a228fa18c0ca8016746e21ffaae85a323062c1 (patch)
tree0f63f03870fb741438505c7c9f3e95bd1bec2a0f
parente2af42d2fd35179ff943def7801725a3c569964c (diff)
downloadaur-e7a228fa18c0ca8016746e21ffaae85a323062c1.tar.gz
npm as dependency and "rm bin/npm" commented
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a0211310fae..5df7063c206d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Sep 13 02:06:49 UTC 2016
+# Wed Oct 26 17:36:46 UTC 2016
pkgbase = prey-node-client
pkgdesc = Remote tracking and monitoring application for laptops, smartphones, and other electronic devices
pkgver = 1.6.3
- pkgrel = 2
+ pkgrel = 3
url = https://preyproject.com/
install = prey-node-client.install
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = prey-node-client
depends = python2
depends = pygtk
depends = networkmanager
+ depends = npm
replaces = prey-tracker
source = prey-node-client.patch
sha256sums = 181785784b44de48ff8ad0601f2a88a00ff4c26fe95b2c075546f23dc54de8c5
diff --git a/PKGBUILD b/PKGBUILD
index dcfca2d67081..33dd699707ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: xpt <user.xpt@gmail.com>
pkgname=prey-node-client
pkgver=1.6.3
-pkgrel=2
+pkgrel=3
pkgdesc="Remote tracking and monitoring application for laptops, smartphones, and other electronic devices"
url="https://preyproject.com/"
arch=('x86_64' 'i686')
license=('GPL3')
-depends=('nodejs' 'mpg123' 'xawtv' 'scrot' 'openssh' 'wireless_tools' 'lsb-release' 'python2' 'pygtk' 'networkmanager')
+depends=('nodejs' 'mpg123' 'xawtv' 'scrot' 'openssh' 'wireless_tools' 'lsb-release' 'python2' 'pygtk' 'networkmanager' 'npm')
replaces=('prey-tracker')
# Should be used as soon as the bash client is renamed
#provides=('prey-tracker')
@@ -22,10 +22,12 @@ sha256sums_i686=('4da7dbc422d1ff7139f565f59c6e8efeace22f60faeabba17cba53a5e7be78
package() {
cd "$srcdir/prey-$pkgver"
+ # Now, we use prey's node, so we don't delete bin/node
+ # --------------------------------
# We don't need the bundled node.js as we have it installed in the system.
# Conveniently, the bash script probes for node.js and automatically uses
# the system node if the bundled one is not found.
- rm bin/node
+ # rm bin/node
# Fix symlink path, Python shebangs and default-disable automatic updates
patch -p0 < ${srcdir}/prey-node-client.patch
@@ -35,6 +37,7 @@ package() {
install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
mkdir -p "$pkgdir/usr/bin/"
+ # Binary prey named as prey_project
ln -s /opt/prey-node-client/bin/prey "$pkgdir/usr/bin/prey_project"
}