summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodney van de Velden2022-05-29 15:25:33 +0200
committerRodney van de Velden2022-05-29 15:25:33 +0200
commita2368a321ca30ae25fead1ea8596dde0b74b3230 (patch)
treee411ee6fcaf3e9a82ff21438f417268b7fc329ef
downloadaur-a2368a321ca30ae25fead1ea8596dde0b74b3230.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e2833f48567
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pridefetch-git
+ pkgdesc = Neofetch clone written in Python with the ability to display pride flags
+ pkgver = r73.c65fb6a
+ pkgrel = 1
+ url = https://github.com/Spyhoodle/pridefetch
+ arch = any
+ makedepends = git
+ makedepends = zip
+ depends = python3
+ depends = python-distro
+ provides = pridefetch
+ source = git+https://github.com/Spyhoodle/pridefetch#tag=vr73.c65fb6a
+ sha512sums = SKIP
+
+pkgname = pridefetch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fdd97ad52c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Rodney van den Velden <rodney@dfagaming.nl>
+
+pkgname=pridefetch-git
+pkgver=r73.c65fb6a
+pkgrel=1
+pkgdesc="Neofetch clone written in Python with the ability to display pride flags"
+arch=('any')
+url="https://github.com/Spyhoodle/pridefetch"
+source=("git+https://github.com/Spyhoodle/pridefetch#tag=v$pkgver")
+depends=('python3' 'python-distro')
+makedepends=('git' 'zip')
+provides=('pridefetch')
+sha512sums=('SKIP')
+
+package() {
+ cd $pkgname/src
+ zip -r ../pridefetch.zip *
+ cd ..
+ echo "#!/usr/bin/env python" | cat - pridefetch.zip > pridefetch
+ install -Dm755 pridefetch "$pkgdir"/usr/bin/pridefetch
+}