summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-23 13:05:17 +0800
committerzxp198210052024-01-23 13:05:17 +0800
commitd923dba7ab9ff19b453d7d4c79e8cec106d84b7d (patch)
tree17fcfbef9a45de85a8362138fe694bce911ef4f7
parenteb78a760aa4d064df4f2c229f93adcc7a0d0720f (diff)
downloadaur-d923dba7ab9ff19b453d7d4c79e8cec106d84b7d.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--primate.sh8
3 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96cdeb3d0513..454aef27e5c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = primate-bin
pkgdesc = A modern dashboard for Kong Gateway admins
pkgver = 1.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.getprimate.xyz/
arch = x86_64
license = MIT
@@ -15,6 +15,6 @@ pkgbase = primate-bin
source = primate.sh
sha256sums = ce23dc5a2e5373b16167817c1f588cee8a6a05c9b02b449e58682821f9e63b55
sha256sums = dd4c137b56da1d126c2aa91b11250f4b1c2973f4dec7f44ce904359bbb1d5612
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = primate-bin
diff --git a/PKGBUILD b/PKGBUILD
index d7fa5530930d..ee4aa018baeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=primate-bin
_pkgname=Primate
pkgver=1.1.0
_electronversion=22
-pkgrel=3
+pkgrel=4
pkgdesc="A modern dashboard for Kong Gateway admins"
arch=('x86_64')
url="https://www.getprimate.xyz/"
@@ -25,13 +25,13 @@ source=(
)
sha256sums=('ce23dc5a2e5373b16167817c1f588cee8a6a05c9b02b449e58682821f9e63b55'
'dd4c137b56da1d126c2aa91b11250f4b1c2973f4dec7f44ce904359bbb1d5612'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --categories "Utility" --name "${_pkgname}" --exec "${pkgname%-bin} --no-sandbox %U"
+ gendesk -q -f -n --categories "Utility" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/primate.sh b/primate.sh
index c77c53567639..aacd8f895847 100644
--- a/primate.sh
+++ b/primate.sh
@@ -6,12 +6,10 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
- exit
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file