summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFeresey2019-10-24 12:47:09 +0300
committerFeresey2019-10-24 12:48:14 +0300
commit28827317b31ce2d9664346d018da9731e6f27503 (patch)
tree9203cb863fb0e33e6ec8c63f59fad25d14bfd413
parentfeabbfd2782225b4e8a086ecba801c691bdff439 (diff)
downloadaur-28827317b31ce2d9664346d018da9731e6f27503.tar.gz
addd license
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD15
2 files changed, 31 insertions, 5 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8aa26455d23a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) [year] [fullname]
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 98708e4ff368..cd8c147784ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ pkgname=prime
pkgdesc="PRIME Render Offload Launcher"
url="https://download.nvidia.com/XFree86/Linux-x86_64/435.21/README/primerenderoffload.html"
pkgver=1.0
-pkgrel=8
+pkgrel=9
arch=('any')
-# license=("nothing")
+license=("custom")
conflicts=(bumblebee)
-depends=(sh)
+depends=(bash)
optdepends=(
"vulkan-intel: for vulkan support"
"lib32-vulkan-intel: for vulkan support"
@@ -18,12 +18,14 @@ source=(prime
prime.install
10-nvidia.conf
zsh_prime
- bash_prime)
+ bash_prime
+ LICENSE)
md5sums=('157eb42ffd9a60c9f61be4e81d62be9d'
'258d0f629572685b52e7f00792ac457e'
'84d31e7be165f77f6c58fe638b4670cb'
'bbc3d71244a5fc5d4d6caeea941ff91f'
- '6597766f7fb79d6d030fbbe20f06e7f0')
+ '6597766f7fb79d6d030fbbe20f06e7f0'
+ '57d76440fc5c9183c79d1747d18d2410')
install=prime.install
@@ -33,10 +35,13 @@ package()
mkdir -p "${pkgdir}"/usr/share/X11/xorg.conf.d/
mkdir -p "${pkgdir}"/usr/share/zsh/site-functions/
mkdir -p "${pkgdir}"/usr/share/bash-completion/completions
+ mkdir -p "${pkgdir}"/usr/share/licenses/prime
install -m a+xr ./prime "${pkgdir}"/usr/bin/
install 10-nvidia.conf "${pkgdir}"/usr/share/X11/xorg.conf.d/
install zsh_prime "${pkgdir}"/usr/share/zsh/site-functions/_prime
install bash_prime "${pkgdir}"/usr/share/bash-completion/completions
+ install bash_prime "${pkgdir}"/usr/share/bash-completion/completions
+ install LICENSE "${pkgdir}"/usr/share/licenses/prime
}