summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2022-12-21 18:03:20 +1000
committergameslayer2022-12-21 18:03:20 +1000
commit3a0a7802b3d599e6b2556b9618f273d634f65b2c (patch)
tree93d207b575bc7e4a1dc7407699b72c2cd8a28196
downloadaur-3a0a7802b3d599e6b2556b9618f273d634f65b2c.tar.gz
committing PKG file to AUR
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60eb078fe4a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = primevideo
+ pkgdesc = Unnofficial Prime Videos desktop application
+ pkgver = 1.0.0
+ pkgrel = 2
+ url = https://gitlab.com/primevideo/application
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = libelectron
+ depends = nss
+ depends = gtk3
+ depends = libxss
+ depends = git
+ conflicts = primevideo-git
+ conflicts = primevideo-bin
+ source = https://gitlab.com/primevideo/application/-/archive/1.0.0-2/application-1.0.0-2.tar.bz2
+ sha256sums = SKIP
+
+pkgname = primevideo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..10d3ed2aaeb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=primevideo
+_pkgname=PrimeVideo
+pkgver=1.0.0
+pkgrel=2
+_pkgrel_x86_64=1
+pkgdesc="Unnofficial Prime Videos desktop application"
+arch=('x86_64')
+url="https://gitlab.com/primevideo/application"
+license=('GPL')
+depends=('libelectron' 'nss' 'gtk3' 'libxss' 'git')
+makedepends=('unzip')
+conflicts=("primevideo-git" "primevideo-bin")
+source=("https://gitlab.com/primevideo/application/-/archive/$pkgver-$pkgrel/application-$pkgver-$pkgrel.tar.bz2")
+sha256sums=('SKIP')
+
+
+package() {
+ for dir in application-$pkgver-$pkgrel ; do mv "${dir}" "$_pkgname" ;done
+ cd "$srcdir/$_pkgname"
+ cat <<EOT >> $pkgname
+ #!/bin/bash
+ cd /opt/$_pkgname &&
+ npm start
+EOT
+
+ chmod +x $pkgname
+ ln -sf "/opt/libelectron/node_modules" "$srcdir/$_pkgname"
+ install -dm755 "$pkgdir/opt/$_pkgname"
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+ cp -r ./ "$pkgdir/opt/$_pkgname"
+ cp -r "$pkgdir/opt/$_pkgname/$pkgname.svg" "$pkgdir/usr/share/pixmaps"
+
+
+ # Link to binary
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "/opt/$_pkgname/$pkgname" "$pkgdir/usr/bin"
+
+ # Desktop Entry
+ install -Dm644 "$srcdir/$_pkgname/$_pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file