summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzethra2016-11-16 15:22:13 -0500
committerzethra2016-11-16 15:22:13 -0500
commitcfc35d15a48af0e8958f77d88e424597f1b19b71 (patch)
tree07294fe0e731df18e8ea165d605812928d935bbc
downloadaur-cfc35d15a48af0e8958f77d88e424597f1b19b71.tar.gz
Created package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9cbbb2f1825
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = primitive-git
+ pkgdesc = Reproducing images with geometric primitives
+ pkgver = r144.37639cc
+ pkgrel = 1
+ url = https://github.com/fogleman/primitive
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ provides = primitive
+ source = primitive-git::git+https://github.com/fogleman/primitive.git#branch=master
+ md5sums = SKIP
+
+pkgname = primitive-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..938c78b9b603
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: zethra <jediben97@gmail.com>
+
+pkgname=primitive-git
+pkgver=r144.37639cc
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+pkgrel=1
+pkgdesc="Reproducing images with geometric primitives"
+arch=('i686' 'x86_64')
+url="https://github.com/fogleman/primitive"
+license=('MIT')
+provides=('primitive')
+source=('primitive-git::git+https://github.com/fogleman/primitive.git#branch=master')
+makedepends=('go')
+md5sums=('SKIP')
+
+build() {
+ GOPATH=$srcdir
+ go get github.com/fogleman/primitive
+}
+
+package() {
+ install -D -m755 "$srcdir/bin/primitive" "$pkgdir/usr/bin/primitive"
+}