summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Morgan2015-08-21 06:34:20 +1000
committerChris Morgan2015-08-21 06:34:20 +1000
commit550cf47b76abb9a872ec8bc67298c84e475070ec (patch)
treea21c747af7b0a3c08d8485c816a8b0db2bc219d5
parentd4eb681c9d00a34ffb36eb05ce01f808bed11e39 (diff)
downloadaur-550cf47b76abb9a872ec8bc67298c84e475070ec.tar.gz
Upgrade to 10r4, use system CA certificates
Thanks to lilydjwg for the suggestion to use the system’s CA certificates bundle instead of the one included in Prince.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ded3a164bfcd..f77994fb6d4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = princexml
pkgdesc = Convert HTML documents to PDF with CSS
- pkgver = 10r2
+ pkgver = 10r4
pkgrel = 1
url = http://www.princexml.com/
arch = i686
@@ -9,10 +9,11 @@ pkgbase = princexml
depends = fontconfig
depends = libidn
depends = libxml2
- source_i686 = http://www.princexml.com/download/prince-10r2-linux-generic-i686.tar.gz
- source_x86_64 = http://www.princexml.com/download/prince-10r2-linux-generic-x86_64.tar.gz
- md5sums_i686 = ca6c74d30d11d33e4bba2b6b65bd6479
- md5sums_x86_64 = 64db57c92cf83e6a460a4c023de2632b
+ depends = ca-certificates-utils
+ source_i686 = http://www.princexml.com/download/prince-10r4-linux-generic-i686.tar.gz
+ source_x86_64 = http://www.princexml.com/download/prince-10r4-linux-generic-x86_64.tar.gz
+ md5sums_i686 = 165db0a887ed9dcf11c45b112ea8a82a
+ md5sums_x86_64 = 926459a17601d70ecfed3daaf048603c
pkgname = princexml
diff --git a/PKGBUILD b/PKGBUILD
index 84dc481f9c80..e38695535009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Chris Morgan <me@chrismorgan.info>
pkgname=princexml
-pkgver=10r2
+pkgver=10r4
pkgrel=1
pkgdesc="Convert HTML documents to PDF with CSS"
arch=(i686 x86_64)
url="http://www.princexml.com/"
-depends=(fontconfig libidn libxml2)
+depends=(fontconfig libidn libxml2 ca-certificates-utils)
license=(custom)
if test "$CARCH" = "i686"
then
- md5sums=('ca6c74d30d11d33e4bba2b6b65bd6479')
+ md5sums=('165db0a887ed9dcf11c45b112ea8a82a')
else
- md5sums=('64db57c92cf83e6a460a4c023de2632b')
+ md5sums=('926459a17601d70ecfed3daaf048603c')
fi
source=(http://www.princexml.com/download/prince-${pkgver}-linux-generic-${CARCH}.tar.gz)
package() {
- mkdir -p $pkgdir/opt/prince
+ mkdir -p "$pkgdir/opt/prince"
- cd ${srcdir}/prince-${pkgver}-linux-generic-${CARCH}/lib/prince
+ cd "${srcdir}/prince-${pkgver}-linux-generic-${CARCH}/lib/prince"
for file in `find -type f`; do
if [ -x "$file" ]; then
install -D "$file" "$pkgdir/opt/prince/$file"
@@ -28,10 +28,14 @@ package() {
fi
done
- mkdir -p $pkgdir/usr/bin
- echo "#!/bin/sh" > $pkgdir/usr/bin/prince
- echo 'exec /opt/prince/bin/prince --prefix=/opt/prince "$@"' >> $pkgdir/usr/bin/prince
- chmod +x $pkgdir/usr/bin/prince
+ mkdir -p "$pkgdir/usr/bin"
+ echo "#!/bin/sh" > "$pkgdir/usr/bin/prince"
+ echo 'exec /opt/prince/bin/prince --prefix=/opt/prince "$@"' >> "$pkgdir/usr/bin/prince"
+ chmod +x "$pkgdir/usr/bin/prince"
+
+ # It provides its own CA certificates bundle, but we want to use our own one.
+ # (This is the cause of the ca-certificates-utils dependency.)
+ ln -sf ../../../etc/ssl/certs/ca-certificates.crt "${pkgdir}/opt/prince/etc/curl-ca-bundle.crt"
cd ../..
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"