summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpzl2018-04-12 19:36:59 -0400
committerpzl2018-04-12 19:36:59 -0400
commitb55e0bc1019c3b5d5658852501b27f90cd340eb2 (patch)
tree7c8c6612ac930de4e753c11bdf9efcb56f9fa2e1
parent4d820aef7789bb6b21f09a3af0e333dbce27a1bd (diff)
downloadaur-b55e0bc1019c3b5d5658852501b27f90cd340eb2.tar.gz
update for python 3 builds
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c7b832d1a07..4696c947e9a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 9 14:59:31 UTC 2018
+# Thu Apr 12 23:34:12 UTC 2018
pkgbase = printrun-git
pkgdesc = Pronterface, Pronsole, and Printcore - Pure Python 3D printing host software and GUI
- pkgver = 1.6.0.20.g20c18cc
+ pkgver = 2.0.0rc5.15.geefc58f
pkgrel = 1
epoch = 1
url = https://github.com/kliment/Printrun
@@ -13,16 +13,16 @@ pkgbase = printrun-git
arch = armv7h
license = GPL
makedepends = git
- makedepends = cython2
- depends = python2-pyserial
- depends = wxpython
- depends = python2-pyglet
+ makedepends = cython
+ depends = python-pyserial
+ depends = python-wxpython
+ depends = python-pyglet
depends = desktop-file-utils
- optdepends = python2-cairo: to use Projector feature
- optdepends = python2-cairosvg: to use Projector feature
- optdepends = python2-numpy: for 3D view
- optdepends = python2-dbus: to inhibit sleep when printing
- optdepends = python2-psutil: to increase process priority when printing
+ optdepends = python-cairo: to use Projector feature
+ optdepends = python-cairosvg: to use Projector feature
+ optdepends = python-numpy: for 3D view
+ optdepends = python-dbus: to inhibit sleep when printing
+ optdepends = python-psutil: to increase process priority when printing
provides = printrun
conflicts = printrun
source = git://github.com/kliment/Printrun.git
diff --git a/PKGBUILD b/PKGBUILD
index 9d87424c401c..ad039ae0b47f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=printrun-git
_gitname='Printrun'
-pkgver=1.6.0.20.g20c18cc
+pkgver=2.0.0rc5.15.geefc58f
pkgrel=1
epoch=1
pkgdesc='Pronterface, Pronsole, and Printcore - Pure Python 3D printing host software and GUI'
@@ -13,14 +13,14 @@ url='https://github.com/kliment/Printrun'
license=('GPL')
provides=('printrun')
conflicts=('printrun')
-depends=('python2-pyserial' 'wxpython' 'python2-pyglet' 'desktop-file-utils')
+depends=('python-pyserial' 'python-wxpython' 'python-pyglet' 'desktop-file-utils')
optdepends=(
- 'python2-cairo: to use Projector feature'
- 'python2-cairosvg: to use Projector feature'
- 'python2-numpy: for 3D view'
- 'python2-dbus: to inhibit sleep when printing'
- 'python2-psutil: to increase process priority when printing')
-makedepends=('git' 'cython2')
+ 'python-cairo: to use Projector feature'
+ 'python-cairosvg: to use Projector feature'
+ 'python-numpy: for 3D view'
+ 'python-dbus: to inhibit sleep when printing'
+ 'python-psutil: to increase process priority when printing')
+makedepends=('git' 'cython')
install="${pkgname}.install"
source=('git://github.com/kliment/Printrun.git')
sha256sums=('SKIP')
@@ -32,10 +32,10 @@ pkgver() {
build() {
cd "${srcdir}/${_gitname}"
- python2 setup.py build
+ python setup.py build
}
package() {
cd "${srcdir}/${_gitname}"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}