summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpzl2018-04-13 09:49:29 -0400
committerpzl2018-04-13 09:49:29 -0400
commite837f5207bea538dc34e816a00572766b51d86a1 (patch)
treeb20b55176b934be1a89e152995ab500e5ec44310
parentb55e0bc1019c3b5d5658852501b27f90cd340eb2 (diff)
downloadaur-e837f5207bea538dc34e816a00572766b51d86a1.tar.gz
add build_ext line to provide smaller g-code parser with cython
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4696c947e9a7..db3b3252fec5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 12 23:34:12 UTC 2018
+# Fri Apr 13 13:49:23 UTC 2018
pkgbase = printrun-git
pkgdesc = Pronterface, Pronsole, and Printcore - Pure Python 3D printing host software and GUI
pkgver = 2.0.0rc5.15.geefc58f
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/kliment/Printrun
install = printrun-git.install
diff --git a/PKGBUILD b/PKGBUILD
index ad039ae0b47f..4937d49baded 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=printrun-git
_gitname='Printrun'
pkgver=2.0.0rc5.15.geefc58f
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Pronterface, Pronsole, and Printcore - Pure Python 3D printing host software and GUI'
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -33,6 +33,7 @@ pkgver() {
build() {
cd "${srcdir}/${_gitname}"
python setup.py build
+ python setup.py build_ext --inplace
}
package() {