summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Muehlhaeuser2020-11-16 02:56:03 +0100
committerChristian Muehlhaeuser2020-11-16 02:56:09 +0100
commit49679fe64c7d3c616cd0398c2510839b347a721f (patch)
treed637af26befef82cac46bfdade3ca196f3cfb7e7
downloadaur-49679fe64c7d3c616cd0398c2510839b347a721f.tar.gz
Initial package prism
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD47
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f371b574dae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = prism
+ pkgdesc = An RTMP stream recaster / splitter
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/muesli/prism
+ arch = x86_64
+ arch = i686
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ source = https://github.com/muesli/prism/archive/v0.1.0/prism-0.1.0.tar.gz
+ sha256sums = 06846e9ffab2bf26755b063db6a46d3ceba0d5fe65e19735a55ba9c415b77255
+
+pkgname = prism
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e28780680a62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
+
+pkgname=prism
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="An RTMP stream recaster / splitter"
+arch=('x86_64' 'i686' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/muesli/${pkgname}"
+license=('MIT')
+makedepends=('go')
+source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('06846e9ffab2bf26755b063db6a46d3ceba0d5fe65e19735a55ba9c415b77255')
+
+prepare() {
+ export GOPATH="$srcdir/gopath"
+ export GO111MODULE=on
+
+ go clean -modcache
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-X main.Version=$pkgver -linkmode external -extldflags \"${LDFLAGS}\"" \
+ -o "$pkgname" .
+
+ go clean -modcache
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=4 sw=4 et: