summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2019-10-11 18:03:52 +0200
committerhashworks2019-10-11 18:03:52 +0200
commit92d16d44acfa5d5cfee4f2813de8e8d9f38de002 (patch)
tree6222e2a18a017bc4aac7dc1a35cfc1ed2a303425
parentdd260ca0ed03af5b1006798a910322f33d4b5ec5 (diff)
downloadaur-92d16d44acfa5d5cfee4f2813de8e8d9f38de002.tar.gz
Use upstream binary package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD41
-rw-r--r--include_qdatastream.patch12
4 files changed, 16 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c70763ac2837..1454c669085f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,18 @@
-# Generated by mksrcinfo v8
-# Thu Dec 10 12:17:41 UTC 2015
pkgbase = prismatik
- pkgdesc = A controler for usb driven LED backlights.
+ pkgdesc = A controller for usb driven LED backlights.
pkgver = 5.11.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/woodenshark/Lightpack
install = prismatik.install
- arch = i686
arch = x86_64
license = GPL3
- makedepends = git
- makedepends = libusb
- makedepends = pkg-config
depends = qt5-serialport
depends = libxkbcommon-x11
provides = lightpack
provides = prismatik
conflicts = prismatik-git
- source = https://github.com/woodenshark/Lightpack/archive/5.11.2.tar.gz
- source = include_qdatastream.patch
- sha256sums = 09163cd082b2c49170c838f06820a13e7afb2c615e3aba523c8b46206325df43
- sha256sums = 788d7bb283a80913d07eeb7b0ed66c00da0869ea71f72861a4c503061ef9075d
+ source = https://github.com/woodenshark/Lightpack/releases/download/5.11.2/prismatik_5.11.2_amd64.deb
+ sha256sums = a97f88a9eec9f91b076d2f6b6117b03470fff71e9b18fe595ebe377220871c6f
pkgname = prismatik
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d30c3c9e8207
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.deb
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index ca3ed4506018..181875e48037 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,20 @@
+# Maintainer: hashworks <mail@hashworks.net>
+
pkgname=prismatik
-_sname=Lightpack
pkgver=5.11.2
-pkgrel=2
-pkgdesc="A controler for usb driven LED backlights."
-arch=('i686' 'x86_64')
+pkgrel=3
+pkgdesc="A controller for usb driven LED backlights."
+arch=('x86_64')
url="https://github.com/woodenshark/Lightpack"
license=('GPL3')
depends=('qt5-serialport' 'libxkbcommon-x11')
-makedepends=('git' 'libusb' 'pkg-config')
provides=('lightpack' 'prismatik')
conflicts=('prismatik-git')
-install='prismatik.install'
-source=(
- "https://github.com/woodenshark/${_sname}/archive/${pkgver}.tar.gz"
- "include_qdatastream.patch"
-)
-sha256sums=(
- '09163cd082b2c49170c838f06820a13e7afb2c615e3aba523c8b46206325df43'
- '788d7bb283a80913d07eeb7b0ed66c00da0869ea71f72861a4c503061ef9075d'
-)
-
-build() {
- cd "$_sname-$pkgver/Software"
- patch -p1 -i ${srcdir}/include_qdatastream.patch
- qmake-qt5 -recursive
- make
-}
-
-check() {
- cd "$_sname-$pkgver/Software"
- make check
-}
+install=prismatik.install
+source=(https://github.com/woodenshark/Lightpack/releases/download/${pkgver}/prismatik_${pkgver}_amd64.deb)
+sha256sums=('a97f88a9eec9f91b076d2f6b6117b03470fff71e9b18fe595ebe377220871c6f')
package() {
- cd "$_sname-$pkgver"
- install -Dm755 "Software/src/bin/Prismatik" "${pkgdir}/usr/bin/prismatik"
- install -Dm644 "Software/dist_linux/deb/etc/udev/rules.d/93-lightpack.rules" "${pkgdir}/etc/udev/rules.d/93-lightpack.rules"
- install -Dm644 "README.md" "${pkgdir}/usr/share/doc/prismatik/README.md"
- install -Dm644 "Software/CHANGELOG" "${pkgdir}/usr/share/doc/prismatik/CHANGELOG"
+ tar xf data.tar.xz -C "${pkgdir}"
+ chmod -R g-w "${pkgdir}"
}
diff --git a/include_qdatastream.patch b/include_qdatastream.patch
deleted file mode 100644
index d8bac2bd3e5e..000000000000
--- a/include_qdatastream.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/qtsingleapplication/src/qtlocalpeer.cpp b/src/qtsingleapplication/src/qtlocalpeer.cpp
-index 332b064..2de5ce2 100644
---- a/src/qtsingleapplication/src/qtlocalpeer.cpp
-+++ b/src/qtsingleapplication/src/qtlocalpeer.cpp
-@@ -40,6 +40,7 @@
-
-
- #include "qtlocalpeer.h"
-+#include <qdatastream.h>
- #include <QCoreApplication>
- #include <QTime>
-