summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadly2015-11-05 18:56:26 +0100
committerTadly2015-11-05 18:56:26 +0100
commitb2987f439cd1804d10e9bc7dc02e4dccb74cfa07 (patch)
treeaecc8d218c44a24a3e8f51ce908cc45dc9b640dd
downloadaur-b2987f439cd1804d10e9bc7dc02e4dccb74cfa07.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
-rw-r--r--include_qdatastream.patch12
-rw-r--r--prismatik.install11
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17199b93e4f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = prismatik
+ pkgdesc = A controler for usb driven LED backlights.
+ pkgver = 5.11.2
+ pkgrel = 1
+ url = https://github.com/woodenshark/Lightpack
+ install = prismatik.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = libusb
+ makedepends = pkg-config
+ depends = qt5-serialport
+ depends = libxkbcommon-x11
+ provides = lightpack
+ provides = prismatik
+ source = https://github.com/woodenshark/Lightpack/archive/5.11.2.tar.gz
+ source = include_qdatastream.patch
+ sha256sums = 09163cd082b2c49170c838f06820a13e7afb2c615e3aba523c8b46206325df43
+ sha256sums = 788d7bb283a80913d07eeb7b0ed66c00da0869ea71f72861a4c503061ef9075d
+
+pkgname = prismatik
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d68ed797b3a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=prismatik
+_sname=Lightpack
+pkgver=5.11.2
+pkgrel=1
+pkgdesc="A controler for usb driven LED backlights."
+arch=('i686' 'x86_64')
+url="https://github.com/woodenshark/Lightpack"
+license=('GPL3')
+depends=('qt5-serialport' 'libxkbcommon-x11')
+makedepends=('git' 'libusb' 'pkg-config')
+provides=('lightpack' 'prismatik')
+install='prismatik.install'
+source=(
+ "https://github.com/woodenshark/${_sname}/archive/${pkgver}.tar.gz"
+ "include_qdatastream.patch"
+)
+sha256sums=(
+ '09163cd082b2c49170c838f06820a13e7afb2c615e3aba523c8b46206325df43'
+ '788d7bb283a80913d07eeb7b0ed66c00da0869ea71f72861a4c503061ef9075d'
+)
+
+build() {
+ cd "$_sname-$pkgver/Software"
+ patch -p1 -i ${srcdir}/include_qdatastream.patch
+ qmake-qt5 -recursive
+ make
+}
+
+check() {
+ cd "$_sname-$pkgver/Software"
+ make check
+}
+
+package() {
+ cd "$_sname-$pkgver"
+ install -Dm755 "Software/src/bin/Prismatik" "${pkgdir}/usr/bin/prismatik"
+ install -Dm644 "Software/dist_linux/deb/etc/udev/rules.d/93-lightpack.rules" "${pkgdir}/etc/udev/rules.d/93-lightpack.rules"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/prismatik/README.md"
+ install -Dm644 "Software/CHANGELOG" "${pkgdir}/usr/share/doc/prismatik/CHANGELOG"
+}
diff --git a/include_qdatastream.patch b/include_qdatastream.patch
new file mode 100644
index 000000000000..d8bac2bd3e5e
--- /dev/null
+++ b/include_qdatastream.patch
@@ -0,0 +1,12 @@
+diff --git a/src/qtsingleapplication/src/qtlocalpeer.cpp b/src/qtsingleapplication/src/qtlocalpeer.cpp
+index 332b064..2de5ce2 100644
+--- a/src/qtsingleapplication/src/qtlocalpeer.cpp
++++ b/src/qtsingleapplication/src/qtlocalpeer.cpp
+@@ -40,6 +40,7 @@
+
+
+ #include "qtlocalpeer.h"
++#include <qdatastream.h>
+ #include <QCoreApplication>
+ #include <QTime>
+
diff --git a/prismatik.install b/prismatik.install
new file mode 100644
index 000000000000..1e51dc482ef3
--- /dev/null
+++ b/prismatik.install
@@ -0,0 +1,11 @@
+post_install() {
+ udevadm control --reload-rules
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}