summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-10-18 08:43:34 +0200
committerSefa Eyeoglu2022-10-18 08:43:34 +0200
commit4ac809e47a871eab4a220594cda77aa492e76332 (patch)
tree740736e7bf891cfc74a6e3faef357aceea49213b
downloadaur-4ac809e47a871eab4a220594cda77aa492e76332.tar.gz
initial commit
Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD65
2 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70d7a8b6d368
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = prismlauncher-git
+ pkgdesc = Minecraft launcher with ability to manage multiple instances.
+ pkgver = 1.4.0.r348.gc089f9b5
+ pkgrel = 2
+ url = https://github.com/PlaceholderMC/PlaceholderMC
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = java-environment
+ makedepends = scdoc
+ makedepends = tomlplusplus
+ makedepends = ghc-filesystem
+ depends = java-runtime
+ depends = libgl
+ depends = qt6-base
+ depends = qt6-5compat
+ depends = qt6-svg
+ depends = qt6-imageformats
+ depends = zlib
+ depends = hicolor-icon-theme
+ depends = quazip-qt6
+ optdepends = glfw: to use system GLFW libraries
+ optdepends = openal: to use system OpenAL libraries
+ optdepends = visualvm: Profiling support
+ optdepends = xorg-xrandr: for older minecraft versions
+ provides = polymc
+ conflicts = polymc
+ options = debug
+ source = git+https://github.com/PlaceholderMC/PlaceholderMC
+ source = git+https://github.com/PlaceholderMC/libnbtplusplus
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = prismlauncher-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7519e204050d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Elijah Gregg <lovetocode999 at tilde dot team>
+# Contributor: Lenny McLennington <lennymclennington@protonmail.com>
+# Contributor: Sefa Eyeoglu <contact@scrumplex.net>
+# Contributor: Miko <mikoxyzzz@gmail.com>
+# Contributor: Cheru Berhanu <aur attt cheru doot dev>
+
+_pkgname=prismlauncher
+pkgname=${_pkgname}-git
+pkgver=1.4.0.r348.gc089f9b5
+pkgrel=2
+pkgdesc="Minecraft launcher with ability to manage multiple instances."
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/PlaceholderMC/PlaceholderMC"
+license=('GPL3')
+depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
+provides=('polymc')
+conflicts=('polymc') # conflicting currently
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus' 'ghc-filesystem')
+optdepends=('glfw: to use system GLFW libraries'
+ 'openal: to use system OpenAL libraries'
+ 'visualvm: Profiling support'
+ 'xorg-xrandr: for older minecraft versions'
+)
+options=(debug)
+source=("git+https://github.com/PlaceholderMC/PlaceholderMC"
+ "git+https://github.com/PlaceholderMC/libnbtplusplus")
+
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "PlaceholderMC"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "PlaceholderMC"
+ git submodule init
+ git config submodule.depends/libnbtplusplus.url "${srcdir}/libnbtplusplus"
+ git config submodule.libraries/quazip.active false
+ git config submodule.libraries/tomlplusplus.active false
+ git config submodule.libraries/filesystem.active false
+ git submodule update
+}
+
+build() {
+
+ cmake -DCMAKE_BUILD_TYPE= \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DLauncher_APP_BINARY_NAME="${_pkgname}" \
+ -DLauncher_QT_VERSION_MAJOR="6" \
+ -Bbuild -SPlaceholderMC
+ cmake --build build
+}
+
+check() {
+ cd "build"
+ ctest .
+}
+
+package() {
+ cd "build"
+ DESTDIR="$pkgdir" cmake --install .
+}
+