summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2023-01-14 15:58:46 +0100
committerSefa Eyeoglu2023-01-14 15:58:46 +0100
commit8c59352df76c7caf05a646f56d7fc14f5f8ab0fe (patch)
treec541aa18c67666290599059623dc95142ccae5a7
parent3b0a1cf8f2f77939ec7c718eecfaebfc72a6877f (diff)
downloadaur-8c59352df76c7caf05a646f56d7fc14f5f8ab0fe.tar.gz
upgpkg: prismlauncher-git 6.0.r156.g3de681d2-1
fix up submodules and dependencies Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba81cf610476..e958f523ef1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = prismlauncher-git
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 5.0.r140.g04b39294
+ pkgver = 6.0.r156.g3de681d2
pkgrel = 1
url = https://prismlauncher.org
arch = i686
@@ -24,6 +24,7 @@ pkgbase = prismlauncher-git
depends = zlib
depends = hicolor-icon-theme
depends = quazip-qt6
+ depends = cmark
optdepends = glfw: to use system GLFW libraries
optdepends = openal: to use system OpenAL libraries
optdepends = visualvm: Profiling support
diff --git a/PKGBUILD b/PKGBUILD
index 908bdd539317..e587c0d15ff0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@
_pkgname=prismlauncher
pkgname=${_pkgname}-git
-pkgver=5.0.r140.g04b39294
+pkgver=6.0.r156.g3de681d2
pkgrel=1
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://prismlauncher.org"
license=('GPL3')
-depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
+depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6' 'cmark')
provides=('prismlauncher')
conflicts=('prismlauncher')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus' 'ghc-filesystem' 'gamemode')
@@ -36,10 +36,13 @@ pkgver() {
prepare() {
cd "PrismLauncher"
git submodule init
+ git config submodule.libraries/cmark.active false
+ git config submodule.libraries/extra-cmake-modules.active false
+ git config submodule.libraries/filesystem.active false
git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
git config submodule.libraries/quazip.active false
git config submodule.libraries/tomlplusplus.active false
- git config submodule.libraries/filesystem.active false
+ git config submodule.libraries/zlib.active false
git submodule--helper update
}