summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-10-20 11:44:13 +0200
committerSefa Eyeoglu2022-10-20 11:44:13 +0200
commitd5ba344e7cf05f431d66102ab5927439a19c9a0d (patch)
treec89cac61039a245e1d6ae0dc315c4cfa77e7fc5a
parentfd0e809371eb9e8b7d9d98e04efebc3672c259cd (diff)
downloadaur-d5ba344e7cf05f431d66102ab5927439a19c9a0d.tar.gz
upgpkg: prismlauncher-git 5.0.r18.ga9d4370a-1
enable submodule again Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecc301106c7d..191abcb5af49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = prismlauncher-git
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 5.0.r0.g41032aaa
- pkgrel = 4
+ pkgver = 5.0.r18.ga9d4370a
+ pkgrel = 1
url = https://prismlauncher.org
arch = i686
arch = x86_64
@@ -29,11 +29,11 @@ pkgbase = prismlauncher-git
optdepends = visualvm: Profiling support
optdepends = xorg-xrandr: for older minecraft versions
provides = prismlauncher
- provides = polymc
conflicts = prismlauncher
- conflicts = polymc
options = debug
source = git+https://github.com/PrismLauncher/PrismLauncher.git
+ source = git+https://github.com/PrismLauncher/libnbtplusplus.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = prismlauncher-git
diff --git a/PKGBUILD b/PKGBUILD
index fa24462f7bc2..577294473ee4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@
_pkgname=prismlauncher
pkgname=${_pkgname}-git
-pkgver=5.0.r0.g41032aaa
-pkgrel=4
+pkgver=5.0.r18.ga9d4370a
+pkgrel=1
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://prismlauncher.org"
license=('GPL3')
depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
-provides=('prismlauncher' 'polymc')
-conflicts=('prismlauncher' 'polymc')
+provides=('prismlauncher')
+conflicts=('prismlauncher')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus' 'ghc-filesystem' 'gamemode')
optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
@@ -22,10 +22,10 @@ optdepends=('glfw: to use system GLFW libraries'
'xorg-xrandr: for older minecraft versions'
)
options=(debug)
-source=("git+https://github.com/PrismLauncher/PrismLauncher.git")
- #"git+https://github.com/PrismLauncher/libnbtplusplus.git")
-sha256sums=('SKIP')
- #'SKIP')
+source=("git+https://github.com/PrismLauncher/PrismLauncher.git"
+ "git+https://github.com/PrismLauncher/libnbtplusplus.git")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "PrismLauncher"
@@ -35,12 +35,11 @@ pkgver() {
prepare() {
cd "PrismLauncher"
git submodule init
- # Git CVE prevents this from working :/
- #git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
+ git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
git config submodule.libraries/quazip.active false
git config submodule.libraries/tomlplusplus.active false
git config submodule.libraries/filesystem.active false
- git submodule update
+ git submodule--helper update
}
build() {