summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2022-10-21 16:54:48 +0530
committertxtsd2022-10-21 17:49:44 +0530
commitec9021513202fbcd4db0b50992e22bf1adc56f07 (patch)
treedd4219f19757c2419dda28c782cdb1d729bf5137
parentd5ba344e7cf05f431d66102ab5927439a19c9a0d (diff)
downloadaur-ec9021513202fbcd4db0b50992e22bf1adc56f07.tar.gz
upgpkg: prismlauncher-git 5.0.r18.ga9d4370a-2
Adjust provides and conflicts Add .gitignore Add co-maintainer Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD6
3 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 191abcb5af49..c94757920e66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = prismlauncher-git
pkgdesc = Minecraft launcher with ability to manage multiple instances.
pkgver = 5.0.r18.ga9d4370a
- pkgrel = 1
+ pkgrel = 2
url = https://prismlauncher.org
arch = i686
arch = x86_64
@@ -29,7 +29,10 @@ pkgbase = prismlauncher-git
optdepends = visualvm: Profiling support
optdepends = xorg-xrandr: for older minecraft versions
provides = prismlauncher
+ conflicts = polymc
+ conflicts = polymc-qt5
conflicts = prismlauncher
+ conflicts = prismlauncher-qt5
options = debug
source = git+https://github.com/PrismLauncher/PrismLauncher.git
source = git+https://github.com/PrismLauncher/libnbtplusplus.git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..baf3157fea9c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+PrismLauncher
+libnbtplusplus
+
+*.tar.gz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 577294473ee4..91ab1627df48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Maintainer: txtsd <code@ihavea.quest>
# Contributor: Elijah Gregg <lovetocode999 at tilde dot team>
# Contributor: Lenny McLennington <lennymclennington@protonmail.com>
# Contributor: Miko <mikoxyzzz@gmail.com>
@@ -7,14 +8,14 @@
_pkgname=prismlauncher
pkgname=${_pkgname}-git
pkgver=5.0.r18.ga9d4370a
-pkgrel=1
+pkgrel=2
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://prismlauncher.org"
license=('GPL3')
depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
provides=('prismlauncher')
-conflicts=('prismlauncher')
+conflicts=('polymc' 'polymc-qt5' 'prismlauncher' 'prismlauncher-qt5')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'tomlplusplus' 'ghc-filesystem' 'gamemode')
optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
@@ -61,4 +62,3 @@ package() {
cd "build"
DESTDIR="$pkgdir" cmake --install .
}
-