summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseth2023-11-06 11:08:39 -0500
committerseth2023-11-06 11:08:39 -0500
commitef2ba17ee8c6c608e7c63d413560c5662ed3f012 (patch)
tree9ea87de76e2d462244449b1a196ffffbd4a4ae96
parent9025b466ba026df31e8f0324ba0769d744d216d3 (diff)
downloadaur-ef2ba17ee8c6c608e7c63d413560c5662ed3f012.tar.gz
use jdk17-openjdk for building again
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1978c95b3835..5a80d69e8a89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = prismlauncher-git
pkgdesc = Minecraft launcher with ability to manage multiple instances.
pkgver = 6.0.r238.gdeed4957
- pkgrel = 3
+ pkgrel = 4
url = https://prismlauncher.org
arch = i686
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = prismlauncher-git
makedepends = cmake
makedepends = extra-cmake-modules
makedepends = git
- makedepends = java-environment=17
+ makedepends = jdk17-openjdk
makedepends = scdoc
makedepends = ghc-filesystem
makedepends = gamemode
diff --git a/PKGBUILD b/PKGBUILD
index 16fe16cc4914..9aebb1bd4dc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=prismlauncher
pkgname=${_pkgname}-git
pkgver=6.0.r238.gdeed4957
-pkgrel=3
+pkgrel=4
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://prismlauncher.org"
@@ -17,7 +17,7 @@ license=('GPL3')
depends=('java-runtime=17' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6' 'cmark' 'tomlplusplus')
provides=('prismlauncher')
conflicts=('prismlauncher')
-makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment=17' 'scdoc' 'ghc-filesystem' 'gamemode')
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'jdk17-openjdk' 'scdoc' 'ghc-filesystem' 'gamemode')
optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
'visualvm: Profiling support'
@@ -50,6 +50,8 @@ prepare() {
}
build() {
+ export PATH="/usr/lib/jvm/java-17-openjdk/bin:$PATH"
+
cmake -DCMAKE_BUILD_TYPE= \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DLauncher_APP_BINARY_NAME="${_pkgname}" \