summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseth2023-06-08 15:18:40 -0400
committerseth2023-06-08 15:18:40 -0400
commite771340ad77d389d188c34d24f4981a9c511021d (patch)
treeee12e18569101e2d87bc2b50f93fbc4d09527a75
parent0d2126af0b949a5415e0d61173e121761f623a2c (diff)
downloadaur-e771340ad77d389d188c34d24f4981a9c511021d.tar.gz
update to 7.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--update.sh5
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00bfc1baa550..50a732975fa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = prismlauncher-qt5
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 6.3
+ pkgver = 7.0
pkgrel = 1
url = https://prismlauncher.org
arch = i686
@@ -23,13 +23,14 @@ pkgbase = prismlauncher-qt5
depends = hicolor-icon-theme
depends = quazip-qt5
depends = tomlplusplus
+ depends = cmark
optdepends = glfw: to use system GLFW libraries
optdepends = openal: to use system OpenAL libraries
optdepends = visualvm: Profiling support
optdepends = xorg-xrandr: for older minecraft versions
provides = prismlauncher
conflicts = prismlauncher
- source = https://github.com/PrismLauncher/PrismLauncher/releases/download/6.3/PrismLauncher-6.3.tar.gz
- sha256sums = fc1896df6422248dbd767d4a82066fe6044ae104354ebf75fc5ae92252f2fb1a
+ source = https://github.com/PrismLauncher/PrismLauncher/releases/download/7.0/PrismLauncher-7.0.tar.gz
+ sha256sums = aef3d368aea8c5c65d6db0d258ef3d0a2965a009f1311568190d2b557ec01833
pkgname = prismlauncher-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 2abc8eebd509..2d4807a8f91c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@
# Contributor: dada513 <dada513@protonmail.com>
pkgname=prismlauncher-qt5
-pkgver=6.3
+pkgver=7.0
pkgrel=1
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
url="https://prismlauncher.org"
license=('GPL3')
-depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt5' 'tomlplusplus')
+depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt5' 'tomlplusplus' 'cmark')
provides=('prismlauncher')
conflicts=('prismlauncher')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'ghc-filesystem' 'gamemode')
@@ -22,7 +22,7 @@ optdepends=('glfw: to use system GLFW libraries'
'visualvm: Profiling support'
'xorg-xrandr: for older minecraft versions')
source=("https://github.com/PrismLauncher/PrismLauncher/releases/download/${pkgver}/PrismLauncher-${pkgver}.tar.gz")
-sha256sums=('fc1896df6422248dbd767d4a82066fe6044ae104354ebf75fc5ae92252f2fb1a')
+sha256sums=('aef3d368aea8c5c65d6db0d258ef3d0a2965a009f1311568190d2b557ec01833')
build() {
cd "PrismLauncher-${pkgver}"
diff --git a/update.sh b/update.sh
new file mode 100644
index 000000000000..de81106a2202
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,5 @@
+# https://gist.github.com/getchoo/7a4dbda9a52c856c082e270bc9bda6db
+name='prismlauncher-qt5'
+link='https://api.github.com/repos/PrismLauncher/PrismLauncher/tags'
+jq_exp='.[0].name'
+regex='^v/'