summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorits_me_mario2023-08-03 01:51:32 +0300
committerits_me_mario2023-08-03 01:51:32 +0300
commit174c124c5d35bce507cb0426201788e950cf3472 (patch)
treee112dfc734eb34805cf812569da6eccb3ca2f8d1
parent23c3b88db00d78b35d06b268407a2a2e2ba503ad (diff)
downloadaur-174c124c5d35bce507cb0426201788e950cf3472.tar.gz
How could've messed up theme installation? Fixed now
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df9b6285cabd..0972d77d587f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="PrismLauncher themes from their official github"
arch=('any')
url="https://github.com/PrismLauncher/Themes"
license=('custom')
-makedepends=('zip' 'git')
+makedepends=('git')
optdepends=('prismlauncher')
source=("${pkgname}::git+https://github.com/PrismLauncher/Themes.git")
sha256sums=('SKIP')
@@ -20,14 +20,9 @@ pkgver() {
}
build() {
- cd "${pkgname}/themes"
- rm -f *.zip
rm -f _prism-theme-installer
- for themeDir in *
- do
- zip -r "${themeDir}.zip" "$themeDir"
- done
_genInstallScript
+ cd "${pkgname}/themes"
}
# dirty hack creating install script
@@ -39,21 +34,22 @@ defaultPath="${HOME}/.local/share/PrismLauncher/themes"
read -p "Specify the directory where you want to install themes (default: ${defaultPath})"$'\n> ' installPath
installPath=${installPath:-$defaultPath}
cd /usr/share/prismlauncher-themes
-for themeFile in *
+for themeDir in *
do
- cp "$themeFile" "${installPath}/"
+ cp -rf "$themeDir" "${installPath}/"
done
echo done
EOF
}
package() {
+ install --mode=755 -D "_prism-theme-installer" "${pkgdir}/usr/bin/_prism-theme-installer"
cd "${pkgname}"
- install --mode=644 -vDt "$pkgdir/usr/share/licenses/$pkgname" LICENSES/*
+ install --mode=644 -Dt "$pkgdir/usr/share/licenses/$pkgname" LICENSES/*
+ mkdir "${pkgdir}/usr/share/prismlauncher-themes"
cd themes
- for themeFile in *.zip
+ for themeDir in *
do
- install --mode=644 -D "$themeFile" "${pkgdir}/usr/share/prismlauncher-themes/${themeFile}"
+ cp -r "$themeDir" "${pkgdir}/usr/share/prismlauncher-themes/${themeDir}"
done
- install --mode=755 -D "_prism-theme-installer" "${pkgdir}/usr/bin/_prism-theme-installer"
}