summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorits_me_mario2023-08-03 00:52:57 +0300
committerits_me_mario2023-08-03 00:52:57 +0300
commit23c3b88db00d78b35d06b268407a2a2e2ba503ad (patch)
treebe302efa825bb1b2af7a9177120ce276e309e2a9
downloadaur-23c3b88db00d78b35d06b268407a2a2e2ba503ad.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD59
-rw-r--r--themes.install4
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25bf8fdd37f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = prismlauncher-themes-git
+ pkgdesc = PrismLauncher themes from their official github
+ pkgver = 2023.06.30_1688154246.r2.ge5851ce
+ pkgrel = 1
+ url = https://github.com/PrismLauncher/Themes
+ install = themes.install
+ arch = any
+ license = custom
+ makedepends = zip
+ makedepends = git
+ optdepends = prismlauncher
+ source = prismlauncher-themes-git::git+https://github.com/PrismLauncher/Themes.git
+ sha256sums = SKIP
+
+pkgname = prismlauncher-themes-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df9b6285cabd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Me is just a random anon from the internet. I'm not related to prism in any way
+# Contact about package issues tho. <bjoel2@i2pmail.org>
+
+pkgname="prismlauncher-themes-git"
+pkgver="2023.06.30_1688154246.r2.ge5851ce"
+pkgrel=1
+pkgdesc="PrismLauncher themes from their official github"
+arch=('any')
+url="https://github.com/PrismLauncher/Themes"
+license=('custom')
+makedepends=('zip' 'git')
+optdepends=('prismlauncher')
+source=("${pkgname}::git+https://github.com/PrismLauncher/Themes.git")
+sha256sums=('SKIP')
+install='themes.install'
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g'
+}
+
+build() {
+ cd "${pkgname}/themes"
+ rm -f *.zip
+ rm -f _prism-theme-installer
+ for themeDir in *
+ do
+ zip -r "${themeDir}.zip" "$themeDir"
+ done
+ _genInstallScript
+}
+
+# dirty hack creating install script
+_genInstallScript()
+{
+cat << 'EOF' >> _prism-theme-installer
+#!/bin/bash
+defaultPath="${HOME}/.local/share/PrismLauncher/themes"
+read -p "Specify the directory where you want to install themes (default: ${defaultPath})"$'\n> ' installPath
+installPath=${installPath:-$defaultPath}
+cd /usr/share/prismlauncher-themes
+for themeFile in *
+do
+ cp "$themeFile" "${installPath}/"
+done
+echo done
+EOF
+}
+
+package() {
+ cd "${pkgname}"
+ install --mode=644 -vDt "$pkgdir/usr/share/licenses/$pkgname" LICENSES/*
+ cd themes
+ for themeFile in *.zip
+ do
+ install --mode=644 -D "$themeFile" "${pkgdir}/usr/share/prismlauncher-themes/${themeFile}"
+ done
+ install --mode=755 -D "_prism-theme-installer" "${pkgdir}/usr/bin/_prism-theme-installer"
+}
diff --git a/themes.install b/themes.install
new file mode 100644
index 000000000000..aa7edb07cf2e
--- /dev/null
+++ b/themes.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo ">> Attention! At the moment, no theme has been installed into PrismLauncher yet"
+ echo ">> Run _prism-theme-installer to install them"
+}