summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Harmathy2017-08-14 13:38:28 +0200
committerMax Harmathy2017-08-14 13:44:19 +0200
commit2f4e75167f5a298fdebe6e6098674701d3f6e225 (patch)
treece71ec2b5f537c4d2a084bc91c86e938f669ac3e
parent7b0830996d15f060b3f563cee5a50abacbce8a55 (diff)
downloadaur-2f4e75167f5a298fdebe6e6098674701d3f6e225.tar.gz
Add check to run test suite
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4474e41e06ed..fbf08803154c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = pristine-tar
pkgdesc = Tool to regenerate a pristine upstream tarball using only a small binary delta file and a copy of the source which can be a revision control checkout.
pkgver = 1.40
- pkgrel = 1
+ pkgrel = 2
url = https://packages.debian.org/sid/pristine-tar
arch = i686
arch = x86_64
license = GPL
+ checkdepends = shunit2
+ checkdepends = diffoscope
depends = perl
depends = xdelta
depends = xdelta3
diff --git a/PKGBUILD b/PKGBUILD
index 6fc947383aeb..f935a240eaf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,14 @@
pkgname=pristine-tar
pkgver=1.40
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to regenerate a pristine upstream tarball using only a small binary delta file and a copy of the source which can be a revision control checkout."
arch=('i686' 'x86_64')
url="https://packages.debian.org/sid/pristine-tar"
license=('GPL')
depends=('perl' 'xdelta' 'xdelta3')
conflicts=('pristine-tar-git')
+checkdepends=('shunit2' 'diffoscope')
source=(http://ftp.debian.org/debian/pool/main/p/${pkgname}/${pkgname}_${pkgver}.tar.xz)
sha256sums=('03e45374f908bf7821a9244f9555d68257070865585574bc5b4cf9d4d39b4e54')
@@ -24,6 +25,13 @@ build() {
make
}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make test
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"