summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimperzer02022-04-19 13:10:02 +0300
committerimperzer02022-04-19 13:10:02 +0300
commitd803f1eb87fb2498829d6471de7f3125e97c45c4 (patch)
tree10e4d7095d68abdf945487b745ab7184abc64329
downloadaur-d803f1eb87fb2498829d6471de7f3125e97c45c4.tar.gz
created package
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD58
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..defe810c7fe9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = privacy-protection-messenger-qt
+ pkgdesc = Privacy Protection Messenger Qt GUI
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/imperzer0/privacy-protection-messenger-qt
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake>=3.0
+ makedepends = qt6-base
+ depends = qt6-base
+ depends = privacy-protection-messenger>=1.2-1
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/CMakeLists.txt
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/main.cpp
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/mainwindow.cpp
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/mainwindow.h
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/call_backend.hpp
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/mainwindow.ui
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/resources.qrc
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/privacy-protection-messenger-qt_uk_UA.ts
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/privacy-protection-messenger-qt_ru_UA.ts
+ source = https://raw.githubusercontent.com/imperzer0/privacy-protection-messenger-qt/master/privacy-protection-messenger-qt_ru_RU.ts
+ md5sums = 208f4dc62ecd087db95961fc095f3f89
+ md5sums = 19701c33c592f57e964d4a4d6e9c64f5
+ md5sums = f55347b6da2079d0867dd9074d85fa0a
+ md5sums = 334adfb9460b7ce460160ca427f320b0
+ md5sums = 4a11723938d5f540812b0f0b52b46ae7
+ md5sums = e3f9ff227d4727c384daad3bcd0fc0a9
+ md5sums = baff22f5e98a6c117c609b3078d4d373
+ md5sums = 05cf19b4d413f0cfbefe3415b4d4e80f
+ md5sums = 43ca58212a0ebb4d303b581844799928
+ md5sums = 980681771058d0cc584f9fa154e5296b
+
+pkgname = privacy-protection-messenger-qt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e94b213c6825
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+/pkg/
+/src/
+*.pkg.tar.zst
+*.txt
+*.hpp
+*.cpp
+*.service
+*.ts
+*.h
+*.ui
+*.qrc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb9587cf7a17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Mainained by imper <imperator999mcpe@gmail.com>
+pkgname="privacy-protection-messenger-qt"
+pkgver=1.0
+pkgrel=0
+pkgdesc="Privacy Protection Messenger Qt GUI"
+author="imperzer0"
+branch="master"
+url="https://github.com/$author/$pkgname"
+arch=('x86_64')
+license=('GPL3')
+depends=("qt6-base" "privacy-protection-messenger>=1.2-1")
+makedepends=("cmake>=3.0" "qt6-base")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+
+_srcprefix="https://raw.githubusercontent.com/$author/$pkgname/$branch"
+_languages=("uk_UA" "ru_UA" "ru_RU")
+_libfiles=("CMakeLists.txt" "main.cpp" "mainwindow.cpp" "mainwindow.h" "call_backend.hpp"
+ "mainwindow.ui" "resources.qrc")
+
+for _lang in ${_languages[@]}
+{
+ _libfiles=(${_libfiles[@]} $pkgname"_"$_lang".ts")
+}
+
+for _libfile in ${_libfiles[@]}
+{
+ source=(${source[@]} "$_srcprefix/$_libfile")
+}
+
+md5sums=('208f4dc62ecd087db95961fc095f3f89'
+ '19701c33c592f57e964d4a4d6e9c64f5'
+ 'f55347b6da2079d0867dd9074d85fa0a'
+ '334adfb9460b7ce460160ca427f320b0'
+ '4a11723938d5f540812b0f0b52b46ae7'
+ 'e3f9ff227d4727c384daad3bcd0fc0a9'
+ 'baff22f5e98a6c117c609b3078d4d373'
+ '05cf19b4d413f0cfbefe3415b4d4e80f'
+ '43ca58212a0ebb4d303b581844799928'
+ '980681771058d0cc584f9fa154e5296b')
+
+build()
+{
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_C_COMPILER=gcc -DCMAKE_CXX_COMPILER=g++ .
+ make
+}
+
+package()
+{
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+} \ No newline at end of file