summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Petri2021-04-22 15:38:42 +0200
committerRichard Petri2021-04-22 15:38:42 +0200
commit86d350587df17ed135a9f16a3362ed449678959d (patch)
tree102e34973c7425b085b5590ee801fbfe57c0abc2
parentfe3e452b8a0a1da2ec9903fde32d66db1915e69c (diff)
downloadaur-86d350587df17ed135a9f16a3362ed449678959d.tar.gz
Move to new git repo and add missing dependencies
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e23aefcb904e..3583ea043ef2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = prjoxide-git
pkgdesc = Project Oxide LatticeSemi 28nm Nexus FPGA Bitstream Database
- pkgver = r265.450bf02
+ pkgver = r348.b5d88c3
pkgrel = 1
url = https://github.com/daveshah1/prjoxide
arch = i686
arch = x86_64
- license = unknown
+ license = ISC
makedepends = cargo
+ makedepends = git
+ makedepends = capnproto
+ makedepends = capnproto-java
provides = prjoxide
conflicts = prjoxide
- source = database::git+https://github.com/daveshah1/prjoxide-db.git
- source = oxide::git+https://github.com/daveshah1/prjoxide.git
+ source = database::git+https://github.com/gatecat/prjoxide-db.git
+ source = oxide::git+https://github.com/gatecat/prjoxide.git
+ source = fpga-interchange-schema::git+https://github.com/SymbiFlow/fpga-interchange-schema.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c38566b279dd..14dfbbf94292 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer: Richard Petri <git@rpls.de>
pkgname=prjoxide-git
-pkgver=r265.450bf02
+pkgver=r348.b5d88c3
pkgrel=1
pkgdesc='Project Oxide LatticeSemi 28nm Nexus FPGA Bitstream Database'
arch=('i686' 'x86_64')
url='https://github.com/daveshah1/prjoxide'
-license=('unknown')
+license=('ISC')
depends=()
-makedepends=('cargo')
+makedepends=('cargo' 'git' 'capnproto' 'capnproto-java')
provides=('prjoxide')
conflicts=('prjoxide')
-source=('database::git+https://github.com/daveshah1/prjoxide-db.git'
- 'oxide::git+https://github.com/daveshah1/prjoxide.git')
+source=('database::git+https://github.com/gatecat/prjoxide-db.git'
+ 'oxide::git+https://github.com/gatecat/prjoxide.git'
+ 'fpga-interchange-schema::git+https://github.com/SymbiFlow/fpga-interchange-schema.git')
sha256sums=('SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -24,6 +26,7 @@ prepare() {
cd "$srcdir/oxide"
git submodule init
git config submodule.database.url "$srcdir/database"
+ git config submodule.3rdparty/fpga-interchange-schema.url "$srcdir/fpga-interchange-schema"
git submodule update
}