summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2022-05-29 20:43:32 +0200
committerXiretza2022-05-29 20:46:49 +0200
commitb4aa36c94e43aaf6a0e3be89ccd622e17b59b1a2 (patch)
treefec647c75bf427474c449a67313e43529ebe46bf
parent2057c762b56a60b6bf49e02f722265d0c93b5ac7 (diff)
downloadaur-b4aa36c94e43aaf6a0e3be89ccd622e17b59b1a2.tar.gz
Fix dependencies, patch for GCC >=11
-rw-r--r--.SRCINFO6
-rw-r--r--0001-fix-set-C-standard-to-14.patch30
-rw-r--r--PKGBUILD14
3 files changed, 45 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 175c16c25f9b..5e44dc686fdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = prjxray-git
pkgdesc = Documenting the Xilinx 7-series bit-stream format
- pkgver = r3579.5937733d
+ pkgver = r3602.51132a11
pkgrel = 1
url = https://github.com/SymbiFlow/prjxray
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = prjxray-git
makedepends = python-fasm
makedepends = python-intervaltree
makedepends = python-numpy
+ makedepends = python-pyjson5
makedepends = python-yaml
makedepends = python-simplejson
optdepends = prjxray-db: The pre-built database
@@ -23,6 +24,7 @@ pkgbase = prjxray-git
source = git+https://github.com/google/cctz
source = git+https://github.com/abseil/abseil-cpp
source = git+https://github.com/jbeder/yaml-cpp
+ source = 0001-fix-set-C-standard-to-14.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -30,6 +32,7 @@ pkgbase = prjxray-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 5f47ffb9b89b976046588968f9a5038da7612211c1a85b396d62a24973941730
pkgname = prjxray-tools-git
depends = gcc-libs
@@ -46,6 +49,7 @@ pkgname = python-prjxray-git
depends = python-fasm
depends = python-intervaltree
depends = python-numpy
+ depends = python-pyjson5
depends = python-yaml
depends = python-simplejson
provides = python-prjxray
diff --git a/0001-fix-set-C-standard-to-14.patch b/0001-fix-set-C-standard-to-14.patch
new file mode 100644
index 000000000000..3009702c4ca8
--- /dev/null
+++ b/0001-fix-set-C-standard-to-14.patch
@@ -0,0 +1,30 @@
+From 10e2d2c8fc16de6eac4579bb022a36b16b8f1b69 Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sun, 29 May 2022 20:31:49 +0200
+Subject: [PATCH] fix: set C++ standard to 14
+
+GCC >= 11 defaults to C++17, but abseil needs to be compiled with the
+same standard as the rest of the codebase, which sets CMAKE_CXX_STANDARD
+to 14.
+
+https://github.com/f4pga/prjxray/issues/1950
+---
+ CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8a20d04a..029fc1f5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,6 +21,8 @@
+ # and then issuing `yum install cmake3` on the command line.
+ cmake_minimum_required(VERSION 3.5)
+
++set(CMAKE_CXX_STANDARD 14)
++
+ # Compiler id for Apple Clang is now AppleClang.
+ if (POLICY CMP0025)
+ cmake_policy(SET CMP0025 NEW)
+--
+2.36.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 9920d72ebc49..f25a3b6d0fe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgbase=prjxray
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-tools-git" "python-$_pkgbase-git")
-pkgver=r3579.5937733d
+pkgver=r3602.51132a11
pkgrel=1
pkgdesc="Documenting the Xilinx 7-series bit-stream format"
arch=(x86_64)
@@ -11,7 +11,7 @@ url="https://github.com/SymbiFlow/prjxray"
license=('ISC')
depends=()
_pythondepends=('python' 'python-fasm' 'python-intervaltree' 'python-numpy'
- 'python-yaml' 'python-simplejson')
+ 'python-pyjson5' 'python-yaml' 'python-simplejson')
makedepends=('git' 'cmake' 'python-setuptools')
makedepends+=("${_pythondepends[@]}")
optdepends=('prjxray-db: The pre-built database')
@@ -22,14 +22,17 @@ source=("git+$url"
"git+https://github.com/gflags/gflags"
"git+https://github.com/google/cctz"
"git+https://github.com/abseil/abseil-cpp"
- "git+https://github.com/jbeder/yaml-cpp")
+ "git+https://github.com/jbeder/yaml-cpp"
+ '0001-fix-set-C-standard-to-14.patch'
+)
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '5f47ffb9b89b976046588968f9a5038da7612211c1a85b396d62a24973941730')
pkgver() {
cd "$_pkgbase"
@@ -52,6 +55,9 @@ prepare() {
cd third_party
git submodule update "${_mods[@]}"
+
+ cd abseil-cpp
+ patch -p1 < "$srcdir/0001-fix-set-C-standard-to-14.patch"
}
build() {